I don't want a login screen!

Josias

macrumors 68000
Original poster
Mar 10, 2006
1,908
1
After fiddling with some settings in Sysprefs > Security, the login windows appears, and I have to type a password. I don'y know how to get rid of this. I just want it automatically to login with no password. There's only one user on this MacBook.

It takes so much longer time to boot when having to type a password, how do I get rid of this?:confused:
 

skunk

macrumors G4
Jun 29, 2002
11,744
4,102
Republic of Ukistan
Josias said:
After fiddling with some settings in Sysprefs > Security, the login windows appears, and I have to type a password. I don'y know how to get rid of this. I just want it automatically to login with no password. There's only one user on this MacBook.

It takes so much longer time to boot when having to type a password, how do I get rid of this?:confused:
Go to System Prefs>Security>uncheck "Disable Automatic Login"
Go to System Prefs>Accounts>click on "Log-In Options" at the bottom, check "Automatically log in as *user*"
 

Josias

macrumors 68000
Original poster
Mar 10, 2006
1,908
1
Grr! It still shows the login screen. And yes, the box s unchecked! WTF?:confused:
 

Josias

macrumors 68000
Original poster
Mar 10, 2006
1,908
1
I don't know, but as earlier stated, I only have one user on this MacBook, and there's never been another user. I don't understand. I though I could switch it off again?:eek:

Yes! Found it, and it worked. I dunno how this was disabled, but I enabled it again anyways:
 

MacsRgr8

macrumors 604
Sep 8, 2002
7,832
1,130
The Netherlands
If you enable the root user, it might switch the "auomatic log in" option off.... not sure to be honest.

Maybe it's that. Or maybe you have an Open Directory master on your network delivering user accounts over DHCP...?