I don't want to use iCloud, but System Preferences nags me to start using it.

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
I don't use iCloud. I used to be able to sign into App Store separately, but now there is a red "1" dot on the System Preferences icon. I can't get rid of the 'Start Using iCloud' message, even though I hit the 'Not Now' button. Urghh... How terribly annoying!

Update: Is no one else bothered by this? I am already on PB 4 and that behavior drives me insane! You can easily dismiss that message in iOS 13 Beta. Not so in Catalina. It will even sign you into iCloud without a password! Privacy nightmare!
 
Last edited:
  • Like
Reactions: twanj

bogdanw

macrumors 6502
Mar 10, 2009
486
284
Update: Is no one else bothered by this?
Solution in Terminal
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs
I have two Catalina beta 7 installations, one was new and the other was upgraded from beta 6. Only the last one had the notification.
 
  • Like
Reactions: kazmac, !!! and avz

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Thank you so much for sharing this, hopefully the issue will be fixed in the official release version of Catalina.
 
  • Like
Reactions: twanj

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Seriously? This is disturbing. Is this to say that anyone can just sign in to a random iCloud account if they know the email address?
Well, what happens exactly is I would sign in to the App Store, or Apple books or Apple music or Apple tv and then I get the "Start using iCloud" prompt. So in essence I sign in to any of the aforementioned but I leave iCloud off. Just out of curiosity, I decided to test what would happen if I proceeded to sign in to iCloud. So I hit the "Start using iCloud" button and it prompts me for a password. I DON'T provide the password, but it signs me in anyway and I see all the syncing options (Photos, Notes, iCloud Drive, Bookmarks, etc).
Update: It doesn't seem to do that in the latest beta.
 

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Solution in Terminal
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs
I have two Catalina beta 7 installations, one was new and the other was upgraded from beta 6. Only the last one had the notification.
So if you clean install Catalina you don't have the impossible to dismiss notification? So far I have only done upgrades over Mojave.
 

bogdanw

macrumors 6502
Mar 10, 2009
486
284
So if you clean install Catalina you don't have the impossible to dismiss notification? So far I have only done upgrades over Mojave.
In a new beta 8 installation, the notification appears after signing in to the AppStore (probably other Apple apps as well).
The good news is the solution still works, you can pair it with restarting Dock for immediate effect:
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock
The bad news is I coundn't disable that top preference pane.
In Mojave, you can disable & hide iCloud preference pane with:
Code:
defaults write com.apple.systempreferences DisabledPreferencePanes -array com.apple.preferences.icloud
and
Code:
defaults write com.apple.systempreferences HiddenPreferencePanes -array com.apple.preferences.icloud
In Catalina, I've tried
Code:
defaults write com.apple.systempreferences DisabledPreferencePanes -array com.apple.preferences.AppleIDPrefPane
and
Code:
defaults write com.apple.systempreferences HiddenPreferencePanes -array com.apple.preferences.AppleIDPrefPane
but it only disables access, while remaining visible.
AppleID.jpg
 

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
In a new beta 8 installation, the notification appears after signing in to the AppStore (probably other Apple apps as well).
The good news is the solution still works, you can pair it with restarting Dock for immediate effect:
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs; killall Dock
The bad news is I coundn't disable that top preference pane.
In Mojave, you can disable & hide iCloud preference pane with:
Code:
defaults write com.apple.systempreferences DisabledPreferencePanes -array com.apple.preferences.icloud
and
Code:
defaults write com.apple.systempreferences HiddenPreferencePanes -array com.apple.preferences.icloud
In Catalina, I've tried
Code:
defaults write com.apple.systempreferences DisabledPreferencePanes -array com.apple.preferences.AppleIDPrefPane
and
Code:
defaults write com.apple.systempreferences HiddenPreferencePanes -array com.apple.preferences.AppleIDPrefPane
but it only disables access, while remaining visible.
View attachment 858049
Thank you for sharing this. I have submitted multiple bug reports with Apple, asking them why the preference pane behavior is inconsistent with the iOS equivalent, but have yet to hear back. As much as I like your solution we shouldn't be forced to resort to the Terminal for ironing out such quirky system behavior.
By the way, I didn't know one can disable access to iCloud in this fashion in Mojave. Very cool info!
 

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
I wonder if you guys are submitting bug reports as well about this issue. The more people complain, the more likely it is for Apple to pay attention. I just hope this is not the beginning of a slippery slope towards iCloud becoming mandatory.
 
  • Like
Reactions: kazmac and twanj

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Still nothing... Already on PB 9. God, this is SO annoying! If this doesn't get fixed I don't know if I will start looking at Linux distros (probably won't, I am too lazy), but I just might... Anyway, just venting...
 
Last edited:
  • Like
Reactions: Stridr69 and twanj

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Thanks! However, my point is NOT to log in to iCloud, but rather only to the App Store, Music, TV, etc. As soon as I log in to let's say Music, I get the nagging red badge on System Preferences icon and the "Start using iCloud" reminder. When I go and click "Not Now" neither the red badge, nor the "Start using iCloud" go away.
 
Last edited:

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
Does anyone know if this issue has been fixed already? I have been away from my computer for over three days.
 

bogdanw

macrumors 6502
Mar 10, 2009
486
284
Does anyone know if this issue has been fixed already? I have been away from my computer for over three days.
It doesn't seem fixed, but I might have found a solution that survives MacOS updates.
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs
defaults delete com.apple.systempreferences DidShowPrefBundleIDs
defaults write com.apple.systempreferences AttentionPrefBundleIDs -dict com.apple.preferences.AppleIDPrefPane -float 0
killall Dock
I did this before updating to Beta 11 and the notification didn't show up again.
 
Last edited:

Sarassine

macrumors member
Original poster
Jun 6, 2019
35
14
It doesn't seem fixed, but I might have found a solution that survives MacOS updates.
Code:
defaults delete com.apple.systempreferences AttentionPrefBundleIDs
defaults delete com.apple.systempreferences DidShowPrefBundleIDs
defaults write com.apple.systempreferences AttentionPrefBundleID -dict com.apple.preferences.AppleIDPrefPane -float 0
killall Dock
I did this before updating to Beta 11 and the notification didn't show up again.
Great work! At least for the time being this stupid badge will go away. However, the "Start using iCloud" prompt still persists. Oh, well. Just seems strange, if this is by design, why doesn't this happen in iOS? Hopefully it is just an overlooked bug.
Thank you for posting this.
 

killhippie

macrumors 6502
Jan 12, 2016
348
264
UK
Yes, still nags in a clean Catalina official release.
Same here, when you say a clean Catalina Official release did you mean a clean install as in wiped the drive in recovery and do a clean install? Its really annoying having that sit there in my dock. :(