i.e. trobles with flex

Discussion in 'Web Design and Development' started by Cabbit, Jul 26, 2007.

  1. Cabbit macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #1
    hi all im having a problem were my flex application will load on every browser except for any internet explorer browser.

    Code:
    <object type="application/x-shockwave-flash" data="../includes-artwork/gallery.swf" width="100%" height="400px">
      alt : <a href="../includes-artwork/gallery_ad.swf">gallery.swf</a>
    </object>
    This is the code, i think its here thats the problem and not the achual application.
     
  2. angelneo macrumors 68000

    Joined:
    Jun 13, 2004
    Location:
    afk
    #2
    If you are using flex builder, use it to generate the html code, cut and paste the relevant object tag from there.
     
  3. tominated macrumors 68000

    tominated

    Joined:
    Jul 7, 2006
    Location:
    Queensland, Australia
    #3
    doesn't ie use an activeX control instead or the object tag?
     
  4. Cabbit thread starter macrumors 68020

    Cabbit

    Joined:
    Jan 30, 2006
    Location:
    Scotland
    #4
    cutting and pasteing the code form the html sample dosnt seem to work. i'll give that another go once i find the folder again. Spotlight seems to have lost it or i've deleted it lol.
     
  5. pengu macrumors 6502a

    Joined:
    Mar 20, 2005
    Location:
    Diddily Daddily...
    #5
    um. w3c suggest using the object tag (as you have) but i imagine IE probably requires the <embed> tag.
     

Share This Page