I found a fix for the delete key (backspace) not working

Discussion in 'Mac Basics and Help' started by aakrusen, Mar 31, 2012.

  1. aakrusen macrumors newbie

    Mar 31, 2012
    For the last few months the delete key (for the backspace function, using fn+delete still worked as the traditional "delete" function) on my wife's wireless keyboard has not been working. We bought a new wireless keyboard thinking that would fix it. Nope, same problem. So it must be the somewhere in the settings or the computer is bad, somehow. I've searched lots of forums and I've tried various combinations in my Google search box to think of how someone might word there response to the problem I've been having. Nothing.

    While I was tooling around in the keyboard section of the system preferences I finally clicked on the little purple question mark in the corner (should have done this months ago) and decided to put my problem in the hands of Mr. Jobs. The answer to my problem had to do with the speech recognition setting which to me seemed like one of the last places to look. We've been having a problem with the mic on her computer (for Skype) and we must have tweaked the settings in there trying to fix the mic issue.

    So here's what I did:
    1. From the Apple menu, choose System Preferences.
    2. In the System submenu (below the Internet & Wireless submenu), click on Speech (for me it's an icon of a microphone).
    3. In the Speech Recognition tab, select "OFF" for the Speakable Items.

    For me this closed a small circle icon (something to do with speech recognition) that I could never get off the desktop. The delete key now worked like it did when we bought the computer. I can backspace now and the fn+delete still works as the typical delete key that I'm used to on my PC keyboard.

    Other people may have other issues with the delete key not working for different reasons but I could not find anything that fixed my specific problem. Hope this helps somebody else.

Share This Page