I got through!

Discussion in 'iPhone' started by ubersalad, Jun 15, 2010.

  1. ubersalad macrumors 6502a

    Joined:
    Feb 26, 2008
    #1
    But it's not the same as what you think. I have 4 lines under my account, but only 1 with subsidized pricing. Tried to go through with that account all day with no avail, but when I accidentally put in the number that isn't eligible for subsidized pricing, somehow it went through right away! So I tried again with my subsidized number and it didn't work. Tried again with unsubsidized number, and again it went straight through.

    Anyone can venture to guess why this might be the case?
     
  2. Geckotek macrumors G3

    Geckotek

    Joined:
    Jul 22, 2008
    Location:
    NYC
    #2
    First, check your cart. See if the phone is there. If it is see if you can complete the pre-order.

    Second, try another browser. If you install a new one, don't let it copy over cookies and settings from your existing browser. I think this all has to do with cached sessions or cookies.
     
  3. ubersalad thread starter macrumors 6502a

    Joined:
    Feb 26, 2008
    #3
    Tried it multiple times with different browsers and checked the cart.

    It's not my cache, I am suspecting something funny going on with the AT&T server.
     

Share This Page