I have a dead G4 iMac.

Discussion in 'Mac Basics and Help' started by macgeek2005, Jun 11, 2006.

  1. macgeek2005 macrumors 65816

    Jan 31, 2006
    Okay, so I have a G4 iMac which was running 10.3.9 just fine, and I erased the hard drive and installed Tiger on it, and it went through the whole start up thing, and then when the screen turned blue, the beach ball started spinning, and then it stopped spinning and it was frosen. We tried everything. We zapped the P-ram, we tried to eject the install CD, we tried to boot up on the install CD.

    We're lucky if the screen even lights up.

    So then we tried Fire-Wire disk transfer mode. I plugged it through firewire into my iBook, and the drive showed up, but before I could run any tests on it, the iMac shut down by itself. It doesn't stay on long enough for us to do any thing with the drive. Now, we finally tried to just boot it up and eject the CD again, and we got this:

    "System Failure: cpu=0; code=00000001 (Corrupt stack)
    Latest crash info for cpu 0:
    Exception state (sv=0x2DD1DC80)
    PC=0x000AB8F8; MSR=0x00001030; etc etc etc"

    It went on for a long while. It all appeard on top of the Apple logo screen.

    What can we do?
  2. sushi Moderator emeritus


    Jul 19, 2002
    Zapping the P-RAM can cause problems, among other things.

    You might try the following technique to see if it works:

    1. Eject (manually if need be) the Install CD.
    2. Unplug the computer.
    3. Press the on button, and hold for about 5-10 seconds.
    4. Repeat step 2 a couple of times.
    5. Leave unplugged for a few hours (at least a couple).
    6. Plug in the computer.
    7. Attempt to start.

    Many times this will clear up things on most models.

    If this doesn't work, try booting from the Panther disc and then do a clean reinstall.

    Keep us informed.
  3. macgeek2005 thread starter macrumors 65816

    Jan 31, 2006
    We manually removed the install CD and put in a panther CD, and boot up on that.

    We went into disk utilities and verified the hard drive. It had numerous problems. It couldn't fix them. I erased the hard drive, and tried to fix it again, this time it worked. It said "The Volume "Macintosh HD" appears to be OK". Good.

    So I started the Panther installation, and about a quarter way through, the screen turned blue, and I get that spinning thing, like as if it's getting ready to shut down.

    I tried the install again, after a reboot, and this time I got a kernel panic in the middle of installation.

    I took out the panther CD and put in Tiger again, and verified and repaired the hard drive one more time. There were no problems found.

    I started the Tiger installation, and it's now almost finished as i'm typing this.

    I think that because we fixed the hard drive problems, it should boot up after it's finished.

    I'll keep you posted.
  4. macgeek2005 thread starter macrumors 65816

    Jan 31, 2006
    The Tiger installation finished succesfully, so, the computer restarted at the end of the installation, and it gave us that kernel panic again.

    We manually took the CD out, and booted up again, and this time it actually got to the welcome screen, it started playing that funky music and started saying "Welcome" in every language imaginable, and then all of a sudden it dissapeared, the screen dimmed, and the mouse froze. I unplugged it.

    That's where I am now, it's sitting there unplugged.
  5. macgeek2005 thread starter macrumors 65816

    Jan 31, 2006
    Alright, after being unplugged for about 20 minutes, I plugged it in, and booted it up. It took me to the welcome screen. I went through the setup process, and got to the desktop, all appears to be well.

    Thanks for the help.
  6. sushi Moderator emeritus


    Jul 19, 2002
    Glad to hear that it's finally working.

    It sounds like you might have a RAM memory problem. It might be the chips, connector or simply where you have intermittent contact issue.

    Try this. Turn off and unplug the computer. Take out the memory. Check the contacts.

    - If they do not look oxidized, then carefully reinsert the memory into the slots.

    - If they look oxidized, use a number two pencil eraser and very gently erase the contacts going from the center of the RAM package towards the edge of the connector. Be sure to do this gently (I can't stress this enough.). The contacts should brighten up a bit. Then carefully reinsert the memory into the slots.

    Then plug in and restart the computer.

    Also, upon re-reading your descriptions, it also sounds like you may have a pending HD issue/failure. Definitely monitor and check your permissions on a regular basis. But most of all, be sure to back up your data regularly.

Share This Page