iPhone I have a problem with my iPhone 4

Discussion in 'iOS 7' started by FatPuppy, Jan 26, 2014.

  1. FatPuppy macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #1
    My iphone thinks that the ear pods are connected and there is no sound, even the music is muted and all this is because the phone caught a drop of water. To make the sound work I have to remove Accessory daemons and all comes back to normal but to remove these daemons, I need to jailbreak and I can t on ios 7.1 beta 4 and I won t downgrade to 7.0.4. Any solutions?
     
  2. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #2
    Not sure what you are looking for ?
    You could turn off the phone and put it in a bag of rice to see if it can absorb the water (but it sounds like the damage is done).
     
  3. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
  4. FatPuppy thread starter macrumors 68000

    FatPuppy

    Joined:
    Jul 14, 2012
    #4
    I have beta 4 but the question is how on earth can I delete some daemons without jailbreaking?
     
  5. AK10R macrumors regular

    Joined:
    Jun 20, 2009
    Location:
    Fairbanks, Alaska
    #5
    Had this happen to my 4 but it was not water. Used a can of air to clean out ear jack of pocket lint. Outside chance it will help...... good luck.

    If you do use the can of air, do a short burst into the air before you use it on the phone. There may be a little condensation in can and the short burst will get rid of it.
     
  6. C DM macrumors Westmere

    Joined:
    Oct 17, 2011
    #6
    Well, if you need to do that (jailbreak essentially), and you still want to have 7.1, then you should be able to do it with beta 3 (instead of 4), or alternatively you can go down to 7.0.4 and do it there.
     
  7. cynics macrumors G4

    Joined:
    Jan 8, 2012
    #7
    I have a problem with my iPhone 4

    I had this happen on my 4S. Insanely annoying because the phone would send all sound to the headphones even a phone call.

    I tried cleaning out the port even though it was very clean. That didn't work.

    Did a simple reset (home button + power button until you see Apple logo) and it fixed it. Very very strange but it's been find since and that was probably a year ago or so.

    Edit, just noticed the water comment and your proficiency with iOS so you already probably tried a reset.

    If bit of compressed air doesn't work I'd go for broke and try electrical contact cleaner on a q-tip with the phone off, maybe even battery pulled if you're handy enough.
     

Share This Page