I have an inch wide white stripe on my screen.

Discussion in 'iMac' started by wolftrack7, Jun 11, 2008.

  1. wolftrack7 macrumors newbie

    Joined:
    May 11, 2008
    #1
    I have an inch wide white stripe that runs from the top to the bottom of my screen. This is on an Imac. The cursor disappears when going through it but pops out on the other side. It doesn't move but I can drag my window back and forth to view the part the stripe covers.

    Any ideas or should I locate a local mac repair person?

    Thanks in advance for any and all help!
     
  2. iToaster macrumors 68000

    iToaster

    Joined:
    May 3, 2007
    Location:
    In front of my MacBook Pro
    #2
    I would contact a repair center. It appears you have a problem with the screen or the cable leading to it, perhaps even the graphics card.
     
  3. bodgerx macrumors newbie

    Joined:
    Feb 14, 2008
    #3
    My brother had exactly the same problem with his iMac screen and he was just out of warranty by a couple of days. New display was the only solution. Apple agreed to pay for a new display unit as a gesture of good will but the service centre charged him over £100 for fitting it!
     
  4. wolftrack7 thread starter macrumors newbie

    Joined:
    May 11, 2008
    #4
    Thanks for the info! I went ahead and took it in to the Apple store. I didn't realize that I still had warranty left on it. They are going to replace my screen.

    Thanks again for your help!
     
  5. Cheffy Dave macrumors 68030

    Cheffy Dave

    Joined:
    Feb 5, 2007
    Location:
    Sunny Florida, on the Gulf Coast in Homosassa Fl
    #5
    THAT's where my adhesive tape went,:eek: just kidding, new screen time.:eek:
     
  6. Queso macrumors G4

    Joined:
    Mar 4, 2006
    #6
    My old 17" iMac G5 did something similar although I had two thinner lines in pink. Apple had it for a week, decided they couldn't get the 17" LCD panel anymore, and offered my a 20" Aluminium iMac as a replacement.

    You could get lucky here :cool:
     
  7. amboycharlie macrumors newbie

    Joined:
    May 18, 2009
    #7
    Call Apple Care

    My 17 inch 6 months out of warrantee had the same problem. First the line was cyan and a pixel wide. I lived with it for a couple of months until the logic board also went. I paid $500 and Apple Care replaced both the board and the display. Within 12 hours there were two lines, then 4, then 6, then 8, then 10. I called them back and they "fixed" it again. It lasted a week. A three inch wide black stripe appeared on the screen. My wife was ready to throw in the towel and let me buy a new one. Again, they replaced the logic board and display. Within three days the white stripe appeared. I called Apple Care again and they offered me a brand new machine.

    Clearly, whatever the problem is, it goes deeper than the logic board or display.
    But their technicians haven't found it and it's proving to be costly for the company. I would expect a wave of 17 inch iMac problems to bite into profitability, and affect the price of the stock very soon.
     
  8. MTI macrumors 65816

    Joined:
    Feb 17, 2009
    Location:
    Scottsdale, AZ
    #8
    11 month old thread revival . . . issue was common with the early Intel iMacs . . . so much so that there's now two lawsuits winding their way through the federal courts in Northen CA.
     

Share This Page