I have some questions on jailbraking my iPod touch

Discussion in 'iPod touch' started by Tnel4455, Aug 18, 2010.

  1. Tnel4455 macrumors newbie

    Joined:
    Aug 17, 2010
    #1
    I am currently running version 4.0(that's what my iPod says)
    I'm planning on using jailbrakeme.com. Because I'm running 4.0 will jailbroken apps work on my iPod? My friend downloaded mewseek on his iPod and it just crashes(he tried both versions)
    *
     
  2. SoraLimit macrumors regular

    Joined:
    Jul 10, 2010
    #2

Share This Page