I heard Xcode cannot work on DP6

Discussion in 'OS X El Capitan (10.11)' started by wwwjfy, Aug 4, 2015.

  1. wwwjfy macrumors newbie

    Joined:
    Jul 9, 2013
  2. GeoffRoynon macrumors newbie

    GeoffRoynon

    Joined:
    Jul 23, 2015
    Location:
    Oxford, UK
    #2
  3. wwwjfy thread starter macrumors newbie

    Joined:
    Jul 9, 2013
    #3
    I know it's working on DP3, I said on DP6
     
  4. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #4
    yep even Xcode 7 beta 4 is broken, hoping for a new Xcode release today or else i'll have to go back.
     
  5. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #5
    * Xcode processes may quit unexpectedly if older iOS Simulator runtimes (Xcode 6.x) are present on disk.

    I'm wondering if I can simply remove the old simulators?? Anyone try that?
     
  6. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #6
    I just deleted Xcode 6.4 and tried Xcode 7 beta 4 but simulator is still crashing.
     
  7. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
  8. SG- macrumors regular

    SG-

    Joined:
    Jun 8, 2015
    #8
    a quick fixed posted on Apple Dev forums to get Xcode 7 working on DP Beta 6 build:

    cd /Applications/Xcode-beta.app (or wherever your Xcode 7 beta 4 is located)
    cd Contents/Developer/Platforms/iPhoneSimulator.platform
    cd Developer/SDKs/iPhoneSimulator.sdk/usr/lib
    sudo mv dyld_sim dyld_sim.orig

    tested it myself and it works.
     
  9. S8ER01Z macrumors member

    Joined:
    Jun 17, 2015
    #9
    This worked for me... both 6.4 and 7 Beta are working.

    Thank you!
     
  10. wwwjfy thread starter macrumors newbie

    Joined:
    Jul 9, 2013
  11. _Pez macrumors newbie

    Joined:
    Aug 1, 2015
    #11

Share This Page