I Installed macOS Catalina on a external ssd and now I can't boot into recovery without it attached.

seulgiRV

macrumors newbie
Jun 15, 2019
1
0
Hi guys, i don't know if i messed up big time, or if I'm just not seeing what i did wrong. Anyways I was trying to install macOS Catalina (10.15) on my 2018 MacBook Air, but I didn't want to install it on my boot drive so I installed it on a external ssd, before I could I went into recovery and enabled External Boot: Allow booting from external media, after that i installed Catalina and everything went great, I did what I had to do and when i tried to turn off External boot i tried going into recovery once more (with the external ssd unplugged) and it started doing internet recovery. I let it do its thing and when it finished it gave me an error of -9000F and apple.com/support, i couldn't figure out the issue, i plugged back in the external ssd and tried going into recovery, and to my surprise it worked, i went into Startup Security Utility and it asked for my admin password on the external ssd not internal, i put it and it doesn't accept my password, no matter what I put it doesn't work, any ideas why?? its not a big issue as the computer works normal, but I would like to fix it. Any help is appreciated.
On a Chinese forum, a user had the -9000F issue as well. Translated, you may want to try formatting the hard drive before restoring if you don’t care about your data. I have this problem but I did not get to try it as the Apple Store has already sent my machine off for repair.
 

adiaga

macrumors newbie
Jul 5, 2019
1
0
This appears to be what I’ve done. I made a bootable USB partition but when I select it holding option during boot, it still defaults to internet recovery and I get the 9000f error.
[doublepost=1559900618][/doublepost]

I finally managed to get to regular recovery but all it lets me do is reinstall Catalina. Praying that works for now as it’s better than having to take a bricked unit in for service.
Hi blasto2236,

How did you get into recovery mode?
 

blasto2236

macrumors 6502a
Nov 4, 2012
778
382
Hi blasto2236,

How did you get into recovery mode?
I wish I had a better answer, but when I finally made it happen it was 4am, I was drunk, and I honestly have no idea lol.

It was one of the various key combos during startup. That's the best I can offer. I just kept doing it over, and over, and over, until finally one of them let me in. Which oddly, was advice I had read either here or in the Apple forums for getting through it. Just keep going until one of them lets you in.

All I could do was reinstall Catalina, but once I managed to do that it reinstalled my recovery partition so I could more safely roll back to Mojave.

I know this is super vague, but hopefully it helps someone.
 

stradify

macrumors member
Jul 4, 2015
84
27
USA
Try rebooting with Command+Option+R. It worked for me.
Like you guys I'm unable to reinstall 10.14.5 from recovery after putting Catalina on an external SSD.
Only the latest Catalina beta shows as available in Recovery.
Since 10.14.5 runs fine for me on my 13" 2018 tbMBP I'm fine with that.
If I need to reinstall Mojave down the road I can boot into a clone containing a copy of the Mojave Installer.
 
Last edited:

Installshield

macrumors member
Good night everyone, I have the same problem with my Mac Mini 2018, I decided to test Catalina on a volume created in the same Macintosh HD Container that already had Mojave.

I know it was stupid

I noticed something that nobody mentioned here. In the screen of the Boot Security Utility (I was asked to update the Boot Security Utility itself). Then I accepted and the system was restarted and this caused the screen with the apple logo to appear even when I boot with the egpu connected (Akitio Node + RX 580), which before did not happen, only gave video when it was already on the logon screen. It turns out that the system hangs on the screen with the logo and it is no longer possible to boot the mac without using the integrated video processor

I have the same apple.com / support -9000F error when I try to do the recovery, and I believe we will only be able to do the recovery when the final version of Catalina is released.

At least I was able to boot with a mojave pendrive, destroyed the partition and reinstalled everything. I ran new tests and I still can not access recovery

I also discovered that it is not possible to reactivate Boot Security Utility protections
It is likely that anyone who has activated them will not be able to disable
 
Last edited:

adr1974

macrumors 6502
Nov 15, 2007
250
25
I have the same issue...and am going to reinstall Mojave. Have never used time machine to migrate...any issues to be concerned with? Does the process literally return the Mac to the exact state it was in before erasing/reinstalling the OS?
 

Installshield

macrumors member
Good Morning ! After testing Catalina Beta 4 here I noticed the following changes:

- The problems with Recovery are solved, both Offline ⌘ + R and Online ⌥ + Estão + R (only in Catalina, if returning to Mojave persists the -9000F problem, but patience right after all sooner or later we will all migrate to Catalina )

- The issue with the Startup Security Utility has also been resolved and individual protections can be enabled and disabled as needed.

- Now when using eGPU, it is still not possible to boot the system with the external video card just as it was in Mojave before testing this Beta, I found two situations ... (looking at Mac mini 2018 from behind)

If you connect the Thunderbolt 3 cable to one of the two ports on the right, the Apple logo screen with a loading bar appears below, but the screen remains static (the loading bar does not fill) and the monitor loses the signal. video.

2 And if I connect the Thunderbolt 3 cable to one of the two ports on the left, the Apple logo screen appears (without the loading bar below), but the screen remains static and the monitor loses the video signal.

After losing the video signal to work I have to take out the Thunderbolt 3 cable and plug it back in, then the login screen appears, no need to have an HDMI cable connected directly to the MAC. The fact that the Apple logo screen now appears when booting using eGPU is a sign that they are working on it (hopefully)
 

jowaju

macrumors member
Mar 7, 2019
69
90
If you can still boot to the Catalina installation on your external USB drive, you can simply install the trial of Carbon Copy Cloner and use it to recreate the recovery partition on your main drive, this should fix whatever is broken and give you a usable recovery partition again.
 

rmendez011

macrumors newbie
Original poster
Jun 4, 2018
23
6
Huntington Park, CA
If you can still boot to the Catalina installation on your external USB drive, you can simply install the trial of Carbon Copy Cloner and use it to recreate the recovery partition on your main drive, this should fix whatever is broken and give you a usable recovery partition again.
I don't know if that's a good idea since I can't change security settings in recovery mode, it doesn't accept my admin password even though I know it's right.
 

Doc69

macrumors 6502
Dec 21, 2005
487
32
I have the same exact issues now several months later and Catalina is already at version 10.15.2. Did anyone solve it?

I'm running Mojave on a 2018 Mac mini. Last week I installed Catalina x2 and Mojave x2 for test purposes on an external TB3 SSD (all volumes are in the same APFS container). Now I can no longer boot into recovery mode unless the external drive is attached. If it's not, then the Mac will go into internet recovery instead but fail after a while with error code -1008F.

I think my problems stem from that the Mojave recovery partition on my internal drive has been deleted or overwritten with one for Catalina. Does anyone know how to fix this? Someone said it could be done with Carbon Copy Cloner, but haven't been able to figure it out. Also, when I boot with the Option key, I only see the 4 external installations and the one internal. No recovery partitions.

I am also now unable to get into the Startup Security Utility when in recovery mode (I have a firmware password enabled). It won't accept my password even though I know it's correct (and the pre-filled user name is from one of the Catalina installations on the external drive, not from the main Mojave on the internal drive). This has happened to me in the past as well on an old MBP after I installed an SSD (APFS) with 3 partitions and 3 installations of High Sierra. After I enabled a firmware password, I was unable to disable it, even though I had the correct password. I eventually solved it but unfortunately forgot what I did.

After calling Apple support, the only advice they had was to take it in to the Apple Store.

Any help would be greatly appreciated.

Update: Booting into recovery mode from an external USB flash drive with the Mojave installer, finally let me get into the Startup Security Utility and disable the firmware password. When booted from the USB drive, I could now choose the user for any of the 5 installations in the drop down menu as opposed to only one choice when booted from cmd+R. And the password that didn't work before worked now.

I also reinstalled Mojave on top of the current installation on my internal drive from the USB installer, but it didn't help. I still can not boot into recovery mode unless the external TB3 drive is attached.
 
Last edited: