I keep loosing movie artwork. What am I missing?

miklovo

macrumors member
Original poster
Dec 18, 2008
84
0
I've searched threads and google but cannot find a specific enough solution to my issue.

All my movies are stored on a TC and everything plays just fine and everything is connected via the network and I've tried all the no-brainers like closing and re-opening iTunes, disconnecting the TC then re-connecting it then re-opening iTunes and pointing to the TC again and still nothing.

Problem is randomly I loose my movie artwork. Sometimes it's there and sometimes I get some up to 3/4 of my artwork but never 100% and never all the time. What am I missing?? It's so frustrating that I've spent all the time tagging all these movies with metadata and then the artwork (and only the artwork, all other data shows up fine) only shows up part of the time...

Please, there must be an easy solution I'm missing!! Any help appreciated..

Thanks!!
 

cmoore49

macrumors regular
Mar 22, 2008
113
13
Perhaps if you spelled " lose " correctly the search might show more results.
 
Comment

miklovo

macrumors member
Original poster
Dec 18, 2008
84
0
Perhaps if you spelled " lose " correctly the search might show more results.
I apologize for my quick mis-spelled post but I did in fact search with correct spelling prior to asking.
 
Comment

robanga

macrumors 68000
Aug 25, 2007
1,657
1
Oregon
Look -I vote we lobby Webster's and all other English dictionary bodies to give up and change lose to " loose" with the amount of it we see on the internet its a losing battle. Stick a fork in it the battle is done :)

Thus "loose" will become one of the words like "bow" and have two meanings.

Whooze with me?

to the original poster. i would try repair permissions and making sure your iTunes library points to the correct folder etc. There is an Apple help article on it i recall.
 
Comment

miklovo

macrumors member
Original poster
Dec 18, 2008
84
0
to the original poster. i would try repair permissions and making sure your iTunes library points to the correct folder etc. There is an Apple help article on it i recall.
Everything is the way it should be. ie..points to correct file folders on network disk, no issues with permissions, etc. I have no issues playing all original files and even those that have "lost" their (not there but their..which is I think even more commonly mis-used that loose and lose...) artwork, as soon as I play the movie the artwork magically appears in cover flow...

I've looked through apple support forums and all I can find is how to reset entire libraries and/or delete and re-import the movie into iTunes....I've however tested this with a few movies with no luck....

Thanks for the constructive response though, appreciate the help
 
Comment

heisenberg123

macrumors 603
Oct 31, 2010
6,498
9
Hamilton, Ontario
Everything is the way it should be. ie..points to correct file folders on network disk, no issues with permissions, etc. I have no issues playing all original files and even those that have "lost" their (not there but their..which is I think even more commonly mis-used that loose and lose...) artwork, as soon as I play the movie the artwork magically appears in cover flow...

I've looked through apple support forums and all I can find is how to reset entire libraries and/or delete and re-import the movie into iTunes....I've however tested this with a few movies with no luck....

Thanks for the constructive response though, appreciate the help

have you tried to restart the ATV, mine does what you describe some times but a restart usually gives me back all my artwork
 
Comment

bohbot16

macrumors 6502a
Mar 22, 2009
674
10
Try this -
Close iTunes, go to ~/Music/iTunes/Album Artwork/Cache and delete what's in there.
 
Comment

mic j

macrumors 68030
Mar 15, 2012
2,656
150
I also had this problem a while back. I fixed it by selecting and deleting all of the files in the iTunes library, then added them all back in. Have not had a problem since doing that.
 
Comment

miklovo

macrumors member
Original poster
Dec 18, 2008
84
0
I also had this problem a while back. I fixed it by selecting and deleting all of the files in the iTunes library, then added them all back in. Have not had a problem since doing that.
That was it!! Took about 4 hours to process all artwork back into iTunes but everything is there and looks great!!

Thanks for the help!!
 
Comment

mic j

macrumors 68030
Mar 15, 2012
2,656
150
That was it!! Took about 4 hours to process all artwork back into iTunes but everything is there and looks great!!

Thanks for the help!!
Yeah...it wasn't painless!!! Glad to be of service.
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.