I know, I know, but I am having a self assigned IP problem.

Discussion in 'macOS' started by Jonknox, Sep 16, 2010.

  1. Jonknox macrumors member

    May 10, 2005
    I just bought a Cisco Linksys WRT120N and set it up. it works great with a PC. However on my computer the wireless will not work, only through a Ethernet cord.

    I am running 10.5.8

    I have tried everything, trust me. I have downloaded noobproof and tried to reset the router/modem done all of that. Nothing seems to be working.

    Please do not merge my thread as I have looked through them all and none of those methods work for me :(

    Any help would be much appreciated!

    Do you know if I upgrade to snow leopard if this problem will be fixed?

  2. eah2119 macrumors regular

    Aug 20, 2010
    You have probably already tried this, but my only advice would be to turn on airport and choose join other network or create network. You can try to figure out what capabilities your computer has with wireless. For example, mine has 802.11 'something'. And check the router. Perhaps the router doesn't work with Mac?
  3. angelwatt Moderator emeritus


    Aug 16, 2005
    I'll share my configuration, which uses a static IP I set. I have a Linksys 54G and I'm using OS 10.6.

    From Network settings in System Preferences
    • Configure IPv4: Manually
    • IP Address: 192.168.my IP (actual numbers that met what my router expects)
    • Subnet Mask:
    • Router:
    • DNS Server:,, (those last two are for Google DNS)
    • Search Domains: empty

    Under Advanced:
    • On TCPIP tab, settings match above
    • DNS lists the same three IPs from above
    • The rest have nothing fancy
  4. Jonknox thread starter macrumors member

    May 10, 2005
    can you walk me through how to do this. I am not sure how to set an IP that is one that my router "expects"

    also I am going to finally upgrade to snow leopard! we will see if that helps!

  5. angelwatt Moderator emeritus


    Aug 16, 2005
    Most of it is fill in the blank. What your router expects will depend on how the router is setup. As part of my router's configuration it has a section for "Starting IP Address" and also a number for maximum DHCP users. If the starting IP is, then you would want to use an IP between that and See your router's manual for more information.

Share This Page