I lost custom folder icons and cannot copy/paste

whbunn

macrumors member
Original poster
May 29, 2009
68
16
I am using a MBP and iMac OS 10.14.3. I HAD several custom icons on folders (a dollar sign on Financial folder etc.). Yesterday they disappeared on both devices.


This morning I did "get info" on item to copy icon (get info was unlocked). Them I opened "get info" on destination folder (unlocked window) and tried to paste icon. The icon did not paste. Simple put I can no longer copy and paste folder icons.


There have been no OS updates that I am aware of. The only thing that happened yesterday was an update of Office 365 apps.


Any Ideas?

Bill
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Gregg

I logged in as root, and the copy/paste works.

Is there a specific Finder plist I should look for?

Bill
[doublepost=1550945633][/doublepost]After experimenting with copy/paste on many different icons and folders I have found that sometimes the copy/paste works and some times not. But it seems to almost always work if I am pasting to a new folder created just to test.
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Beginning on about 2/19 all custom folder icons ( folders in DB )disappeared and reverted to default icons. I tried to recopy and paste but it didn't work.

After much experimenting, I found this problem only occurs to folders in my Dropbox.

That is if I create a folder on my desktop (not in DB) and give it a custom icon. All is well. When I move the folder into DB the custom icon vanishes and reverts to the default icon.

I cannot paste a custom icon to a folder which is in DB, but if I darg folder out I can give it a custom icon. Once it goes into DB it is gone.

Help please.

Bill
 

x_man_

macrumors member
Sep 22, 2015
39
11
Well… just to check what you wrote, I googled for folder icons images, copied some of them directly ("copy image") from the results page and paste them into the icon at the Get Info window of some folders in my Dropbox folder. Everything works. I'm using the latest macOS 10.14.4 Beta (18E194d).
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Well… just to check what you wrote, I googled for folder icons images, copied some of them directly ("copy image") from the results page and paste them into the icon at the Get Info window of some folders in my Dropbox folder. Everything works. I'm using the latest macOS 10.14.4 Beta (18E194d).
[doublepost=1550952543][/doublepost]I am using latest public release of OS. I wish I could tell you different but every time I move folders into DB the customer icon disappears immediately.

Thanks
 

x_man_

macrumors member
Sep 22, 2015
39
11
Try this into one of the folders with custom icon: Press Command+Shift+. (period) to show in the Finder the invisible files and look for the file "icon?". Does this file disappears when you move this folder into de Dropbox folder? Is Dropbox omitting the synchronization of this hidden file?
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Using Press Command+Shift+. (period) on folder not in DB it reveals a file".gif". When I move folder into DB the ".gif" file does NOT appear in DB.

thanks, i have also contacted DB support.

Bill
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16

Gregg2

macrumors 603
May 22, 2008
5,831
353
Milwaukee, WI
Gregg

I logged in as root, and the copy/paste works.

Is there a specific Finder plist I should look for?
Option>Go>Library/Preferences
com.apple.finder.plist
Delete or move to Desktop
Restart

If that doesn't help, I'd create a new User Account and move files over to it. It's not worth the effort to try to pinpoint what is causing the problem.
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Option>Go>Library/Preferences
com.apple.finder.plist
Delete or move to Desktop
Restart

If that doesn't help, I'd create a new User Account and move files over to it. It's not worth the effort to try to pinpoint what is causing the problem.
[doublepost=1551021463][/doublepost]Gregg2

Thanks for your time and suggestions. Deleting .plist for finder did not help, nor did rebuilding launch services.

I have sent report to Dropbox. Maybe they have an idea

Regards
Bill
 

whbunn

macrumors member
Original poster
May 29, 2009
68
16
Turns out I was using beta version of DB. when I went back to public version my problem disappeared