I message issue - Still showing as text message

Discussion in 'iOS 5 and earlier' started by cssvt, Oct 13, 2011.

  1. cssvt, Oct 13, 2011
    Last edited: Oct 13, 2011

    cssvt macrumors newbie

    May 27, 2010
    I should probably mention that I am still not fully awake with that title *iMessage* OOPS!

    I have a friend in Canada and I'd like to send him an iMessage yet every time I put in his number all of the window stays green and it identifies as a text. I know he's on iOS5 as we talked about it via Words With Friends, yet I'd rather not test it and then get charged for an international text. Is there something I'm missing here? iMessage seemed to work fine with my cousin last night, but it doesn't appear to be in this case.

  2. JeffMonty macrumors member

    Feb 14, 2008
    Before you can activate iMessage feature on iPhone, you will need to install iOS 5 to iPhone first.

    Once you have iOS 5 installed on your device, then you’re eligible to use iMessage. However, iMessage feature needs to be activated through the settings.

    Follow these steps to activate iMessage:

    Tap Settings → Messages

    You can activate iMessage by tap or slide it over to turn iMessage on.

    Once activated, there are some new options appearing on the Messages setting screen.

    via http://senseiphone.com/howto-activate-configure-imessage-ios-5-0921731/
  3. cssvt thread starter macrumors newbie

    May 27, 2010

    We both have iOS5 and, as I mentioned, it worked last night when using it with my cousin. Just not working now. Checked my settings and everything is set to default to iMessage if possible, as appears to be default.
  4. Macaddict16 macrumors 6502

    Oct 7, 2002
    From what I have found out so far, you have to text the person once as a text message and then the next time it should see them as an iMessage user. Right now your phone has no way of knowing that the other phone is running iOS 5. Hope this helps.

  5. FSMBP macrumors 68020


    Jan 22, 2009
    That's not true. Once you select a contact, it checks Apple's server to see if their registered - I did this with a new contact who I've never texted before.

    From what I hear, Apple's servers are still slammed - so try again. It wasn't too smart of them to release 3 major updates in one day.
  6. cssvt thread starter macrumors newbie

    May 27, 2010
    Understandable. I also told my friend to check his settings. Mine defaulted to use iMessage but I guess it's possible that his did not.


Share This Page