I messed up...

Discussion in 'macOS' started by martinmartin, Feb 12, 2008.

  1. martinmartin macrumors 6502

    Joined:
    Jun 5, 2007
    #1
    I need a little help...

    Downloaded 10.5.2 last night.

    Decided for some reason that I would also download 'Glass Folder Icons.' Downloaded them from the apple site and 'dragged and dropped' them into my 'CoreTypes.bundle' folder. I logged out/in and saw that the folder icons had updated.

    Then for some reason I repaired permissions and a bunch of notifications came up regarding the changes I had just made. After that, all of my folder icons are just blank documents (see attached). I went into time machine and grabbed the old icons and replaced the new ones to try to undo the damage. Replaced most of the Glass Icons with the old ones from TM, but I'm still just seeing blank document icons for most of the icons.

    Please help!!! Thanks.

    (and, for some reason, my .jpg screenshots are now defaulting to open with IE in parallels and they won't open in Preview??)
     

    Attached Files:

  2. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #2
    Any OSX gurus out there than could provide a little guidance my way...would be much appreciated.

    Cheers.
     
  3. Sherman Homan macrumors 6502

    Joined:
    Oct 27, 2006
    #3
    Let's try one thing first, in the Finder, go up to Finder in the menu bar, down to Preferences. Click on Advanced, put a check mark next to Show all file extensions, close the window.
    Now, click on a jpeg file, just once, to highlight it. Up to the menu bar, File, down to Get Info. Under Open with select Preview (if that is the program that you want to use to open jpegs) and click Change All...
    See if that fixes the specific problem with jpegs. Good luck!
     
  4. martinmartin thread starter macrumors 6502

    Joined:
    Jun 5, 2007
    #4
    Thanks Sherman - after replacing the 'Glass' icons with the originals, and then repairing permissions, logging out/in, everything *appears* to be back to normal. There are still some 'glass icons' left over that i didnt replace because i didnt find the same one in my TM backups, but i havent seen anything strange happen yet.

    Thanks again for the help.

    Next time i wont going playing in the system folder where i dont know whats going on...
     
  5. Sherman Homan macrumors 6502

    Joined:
    Oct 27, 2006
    #5
    'specially right after a system update!
    Glad it worked out!
     

Share This Page