I Miss Internet Explorer

Discussion in 'Mac Basics and Help' started by doubledecaf, Dec 29, 2009.

  1. doubledecaf macrumors newbie

    Joined:
    Dec 27, 2009
    #1
    Ok so I've had my new iMac for a week now, all is great except the internet. Its connected wirelessly, but either goes really slow or websites just say loading. All the PC's in the house work fine.

    Airport is connected - however even though it is connected is always searching for networks?

    The Safari is slow and sometimes doesn't work at all. However always works upon a quick computer restart.

    I wonder whether I've changed a setting by accident, or is wireless just not very good on macs?

    Any advice would be great! Thanking you in advance!
     
  2. dukebound85 macrumors P6

    dukebound85

    Joined:
    Jul 17, 2005
    Location:
    5045 feet above sea level
  3. KoolStar macrumors demi-god

    KoolStar

    Joined:
    Oct 16, 2006
    Location:
    Kentucky
    #3
    Try Chrome and let me know how that goes. I use it on my windows, mac, and linux machines.
     
  4. spinnerlys Guest

    spinnerlys

    Joined:
    Sep 7, 2008
    Location:
    forlod bygningen
    #4
    Maybe your router is not working properly with Macs.

    You can share your settings (iMac and router), to see if they might be the source of the problem.

    Also the iMac's wireless antenna is inside the Apple on the back of the iMac, so how far away is the router.


    And PS, Internet Explorer has nothing to do with reception.
     
  5. JediMeister macrumors 68040

    Joined:
    Oct 9, 2008
    #5
    Are any of the other computers actively using the internet, downloading, streaming anything when you try to access it on the Mac? The AirPort menu will always rescan for available networks, there's nothing unusual in that process. Couple suggestions: 1) update your Mac OS and Safari, there's a chance you may be missing a component that will jump-start your web experience, 2) reset Safari via the Safari menu, make sure you empty the caches and cookies, 3) if you suspect you changed anything in the network settings for the computer that is causing this, you can create a new Network location via Network preferences, click where it says Automatic or whatnot and Edit Locations to create a new one and apply it. Something that step 3 will counteract is manually inputted DNS or proxy settings, which could artificially make the internet connection appear slower than it actually is.

    *No one else has mentioned this but try power cycling the router/modem...
     
  6. Jaro65 macrumors 68040

    Jaro65

    Joined:
    Mar 27, 2009
    Location:
    Seattle, WA
    #6
    Or use Firefox. But most importantly, make sure that you have a good Internet connectivity. Press the 'option' key on your keyboard and while holding it click on the WiFi icon in the top menu bar to see what Transmit Rate you're getting.
     
  7. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #7
    No, wireless is good on Macs. The fact it works after restart suggests something not configured correctly. Tell us about yuor network setup and the preferences concerning netwoking.
     
  8. mnobre macrumors newbie

    Joined:
    Oct 28, 2009
    #8
    tbh doesn't sound like a browser situation, try connecting to a rj-45 cable and see if you notice a difference, if it changes maybe some router config work is what you need.

    btw shame on you IE is suckiest browser ever!!!!
     
  9. doubledecaf thread starter macrumors newbie

    Joined:
    Dec 27, 2009
    #9
    Here is a little more information!

    Thanks for everyones input - I cant believe how quick everyone is to help! I did an online speed test and everything is running above the 3 Mbps (think thats right).

    I hope these screenshots help.
     

    Attached Files:

  10. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #10
    Your computer updates the network list when you open the AirPort menu. That's what you're seeing. It isn't searching constantly.

    You can try Firefox or Chrome instead of Safari.
     
  11. vohdoun macrumors 65816

    vohdoun

    Joined:
    Jan 23, 2006
    Location:
    Far away from Earth.
    #11
    I think I see the problem. Is the BT Home Hub your router? if it is I've read nothing but problems with these on ThinkBroadband. They are buggy beyond belief.
     
  12. typofreak183 macrumors newbie

    Joined:
    Jun 7, 2009
    Location:
    Utah
    #12
    I'm confused. How does Internet Explorer have anything to do with internet connectivity?

    I would guess, at a glance, that your router is having problems interacting with your Mac. Some routers require drivers to function properly, but generally you can get by without them.

    If you're looking for fast, I would highly recommend checking out Opera 10 and, once installed, turning on Turbo. It's not the forum favorite (I use Firefox myself), but should help if your connection feels a bit dodgy:)
     
  13. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #13
    It lets in all the scripts in that other browsers block. Great Microsoft product if you like the bad guys to come into your computer...
     
  14. Winni macrumors 68030

    Winni

    Joined:
    Oct 15, 2008
    Location:
    Germany.
    #14

    This is not a web browser problem -- it's a Snow Leopard issue. Apple broke the wireless networking with Airport cards (and non-Apple routers) in Snow Leopard and even after the latest updates has not been able - or unwilling - to fix it.

    I "fixed" the problem by buying a HAMA USB Stick for EUR 18 and by no longer using the built-in Airport card of my Mac Pro. Since then the wireless network works again, stable and fast.

    And here is the typical disclaimer for the typical comments: No, my Airport card is not broken - it works perfectly fine, reliable and fast in Linux and Windows. Read it from my lips: This. Is. A. Bug. In. Mac. OS. X.
     
  15. toolbox macrumors 68020

    toolbox

    Joined:
    Oct 6, 2007
    Location:
    Australia (WA)
    #15
    Have you tried putting in static ip / dns settings? If you cable the mac do the websites load quicker?

    Also i would strongly advise ( if the router supports it) to change your wireless security from WEP to WPA/WPA2.
     
  16. eawmp1 macrumors 601

    eawmp1

    Joined:
    Feb 19, 2008
    Location:
    FL
    #16
    Run a Cat5e/6 cable. Wired beats wireless on all computers. If this solves the problem it is either unhappiness between the Mac and your wireless router or as suggested above the Snow Leopard issue.

    OBTW look at comparative benchmarks on the browsers. IE is slower than Safari.
     
  17. Primejimbo macrumors 68040

    Joined:
    Aug 10, 2008
    Location:
    Around
    #17
    I wish Chrome wasn't still beta. I'll wait until it's not beta and try it then.
     
  18. GoKyu macrumors 65816

    GoKyu

    Joined:
    Feb 15, 2007
    Location:
    New Orleans
    #18
    It may be a little cliché, but true... "Friends don't let friends use IE" :)
     
  19. ecualegacy macrumors regular

    Joined:
    Oct 3, 2009
    Location:
    Des Moines, IA
    #19
    I had slow webpage loading for the first month. I DON'T use it wirelessly, but the following fixed my speed problem.

    Changing Configure from Automatically to MANUALLY and the Duplex to FULL DUPLEX did the trick for me. Hope this is of use.
     
  20. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #20
    Yeah, except full-duplex is something that happens inside an ethernet cable. If there's no ethernet cable, it doesn't happen.
     

Share This Page