I need help finding Plex hidden files

Discussion in 'Mac Apps and Mac App Store' started by Sill, Jan 29, 2015.

  1. Sill, Jan 29, 2015
    Last edited: Jan 29, 2015

    Sill macrumors 6502

    Joined:
    Nov 14, 2014
    #1
    After trying Plex out I was extremely dissatisfied with it and I'm now trying to delete it. Their instructions don't get everything, and the tricks I've found here and on other sites haven't found everything.

    I had a lot of trouble installing this thing. I found that you have to have Flash enabled, and also cookies turned on in Safari, things Plex doesn't mention in their support docs.

    When I finally got the application going, it took forever to get any kind of dialogs or options up. I found out later that it had scanned my HD without asking me. I was really angry when I found out it had loaded my entire photo album even though I hadn't pointed it at any of my media. Then it brought up a setup wizard. I answered some rudimentary questions. Finally, it brought up a really poorly designed UI. I poked around for a while but wasn't impressed. It was a lot of trouble for something that wasn't any better for me than HomeSharing. I decided to go back to iTunes, especially since it had native support for aTV.

    After fighting with Plex for a while I deleted it. I also deleted everything associated with it, as instructed in the Plex support docs. After cooling off for a few days I decided to try it again to see if maybe I didn't do something right in the install. So I downloaded it and tried again.

    This time, it skipped the wizard and went right to a page named "channels" (I think). Everything was already loaded in, same as last time. It even had the "friendly" name I had entered for the machine.

    I deleted everything again, and reinstalled the app just to see if it started as a fresh install. It came right up, no wizard, no configure necessary. I deleted everything and went on a witch hunt, finding and destroying things associated with Plex. I reinstalled, once again the app came right up, no wizard loaded, no config required.

    Then I ran a script someone posted for killing Plex. I also used the instructions GGJ posted for killing Plex. I reinstalled it, and instead of going to the wizard, it came back up like it was never gone.

    Now maybe I'm just being too picky, but if I delete everything associated with a program according to the developer's instructions, it shouldn't have a single piece of code remaining. Even their instructions for the wizard tell you deleting these things will enable you to relaunch the setup wizard. Not true.

    Where is this stuff hiding at? How do I kill Plex for good?
     
  2. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #2
    That is strange because Plex is amazing.

    Anyways, try deleting ~/Library/Application Support/Plex Media Server
     
  3. Sill thread starter macrumors 6502

    Joined:
    Nov 14, 2014
    #3
    Not for this guy.

    Already done. I've deleted everything according to Plex Support, and the information is still hidden somewhere on my machine.
     
  4. boast macrumors 65816

    boast

    Joined:
    Nov 12, 2007
    Location:
    Phoenix
    #4
    Ahh yeah I see that is all in the documentation.

    I don't see what else it can be, but I would run find / -name "*plex*" > results in terminal and then check the results file
     
  5. GGJstudios macrumors Westmere

    GGJstudios

    Joined:
    May 16, 2008
    #5
  6. robgendreau macrumors 68030

    Joined:
    Jul 13, 2008
    #6
    If Plex installs from a package, I'm guessing the left behind stuff is in a BOM/receipt in ~/Library/Receipts of /Library/Receipts.

    Another way to look for stuff is to reinstall and then look at the log in the Console of what just got installed. A caveat, however: sometimes an installer will install something that is shared by other applications. Sure, you don't need it for Plex, but you might need it for some other application.
     
  7. Sill thread starter macrumors 6502

    Joined:
    Nov 14, 2014
    #7
    You probably didn't see that I posted this:

    I saw your post from about a year ago and followed it to the letter. I didn't find anything in there. I do appreciate your efforts - that is some good advice for people who forget that in the Spotlight Era, the old Find File is still hidden in the Finder.

    ----------

    Sounds like a .dll - shades of Windows, blech.

    I didn't find anything in /Receipts, but I think this is a valuable lead. Got anything else?
     
  8. grahamperrin, Jul 17, 2016
    Last edited: Jul 17, 2016

    grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #8
    For packages, receipts and bills of materials (BOMs), pkgutil(1) is our friend. However: current version 1.0.0 of Plex.app (1.0.0.2261 in the web interface to the server) is drag and drop; no use of Installer, no receipt.

    From a FreeBSD perspective (I use TrueOS Desktop), neither http://www.freshports.org/multimedia/plexmediaserver/ nor http://www.freshports.org/multimedia/plexhometheater/ mentions Flash, so I guess that a requirement for Adobe's player may arise from a Flash medium – not from Plex media server.

    At the Mac where I'm testing the server, I set Plex to open at login but in Terminal, the following command finds nothing –

    sudo launchctl list | grep -i plex

    – maybe nothing because recently, I find it necessary to run macOS Sierra in safe mode … although I checked launchctl-related directories and found nothing Plex-related, so I don't yet know how Plex respects the login preference.

    I used Apple Instruments to trace file Plex file activity from first run of the app, to quit. A path-sorted view of writes reveals nothing unusual; the app does appear to be a good Mac citizen.

    @Sill are hidden files still a concern, or did you move on?

    Side note: I'm not yet an active user of Plex, my interest arose a few months ago from its integration with PC-BSD (the forerunner to TrueOS Desktop). And long before that, when I began using FreeNAS (for reliable Time Machine service and so on), I noted that available plug-ins included one for Plex.
     
  9. kiwipeso1 Suspended

    kiwipeso1

    Joined:
    Sep 17, 2001
    Location:
    Wellington, New Zealand
    #9
    You will find that the Plex server is connected online to your account, so it is likely that your preferences are in the cloud.
     
  10. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #10
    I use an app call easyfind, and that's so much better then OS X's Spotlight. I use that whenever I need to find the bits of an app strewn across my system.
     
  11. Sill thread starter macrumors 6502

    Joined:
    Nov 14, 2014
    #11
    Its definitely still a concern. I tried Plex a couple times more after my initial disgust - I keep an open mind about these things - but I was still not happy with the result and I ended up deleting it again. In each and every case, Plex didn't scan my drive for media files because the data was already there. There has to be a file or files stored somewhere on the host computer that keeps this information.

    BTW, did you put the '@' sign in front of my name in your post or did the MF forum software do that?
    --- Post Merged, Jul 23, 2016 ---
    I don't have an account. In fact when I did the initial install I disconnected the host from the net after the download. I felt this was valid since I was planning to run the software on a machine that wasn't connected to the net in the first place. Plus, I was very suspicious about Plex insisting that an account wasn't necessary but then at every step they tried to "encourage" me to get an account. Since then, they've all but completely deleted mentions of the account not being necessary.

    I've since moved on to Infuse, which does exactly what I needed, no account necessary, no third party taking notes on what media I have on my machines.
     
  12. AtomicGrog macrumors regular

    Joined:
    Jul 25, 2011
    #12
    Is it possible that the settings are held online on a Plex server and it's associating your install against that using something like your machines serial number?
     
  13. Sill thread starter macrumors 6502

    Joined:
    Nov 14, 2014
    #13
    Not possible. When I did the install I didn't have the machine connected to the net.
     
  14. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #14
    Yep.

    Thanks. I found https://itunes.apple.com/gb/app/infuse-elegant-video-player/id577130046?mt=8 leading to https://support.firecore.com/hc/en-us/categories/202279357-Infuse-for-iPhone-iPad-and-Apple-TV and https://support.firecore.com/hc/en-us/categories/202279067-MiRow-Front-Row-OS-X- … I can't tell whether FireCore's MiRow - Front Row (OS X) requires, or is an alternative to Apple's Front Row. I was puzzled by Apple's abandonment of the software.
     
  15. steve23094 macrumors 68000

    steve23094

    Joined:
    Apr 23, 2013
    #15
    Because it was replaced by the Apple TV, which in itself stagnated for a while until the most recent edition.

    I use Plex.
     
  16. grahamperrin macrumors 601

    grahamperrin

    Joined:
    Jun 8, 2007
    #16
    Thanks @steve23094

    (I never took an interest in Apple TV, and the removal of features from Mac OS X did not inspire me to spend money on additional hardware.)
     
  17. Sill thread starter macrumors 6502

    Joined:
    Nov 14, 2014
    #17
    Thanks for the info. I need to check that out.
     

Share This Page