I NEED HELP!! for Macbook, PLEASE READ

Discussion in 'MacBook' started by xlfodlx, Apr 12, 2008.

  1. xlfodlx macrumors newbie

    Joined:
    Apr 12, 2008
    #1
    I have a Macbook here that will turn on, battery is fine, and AC adapter is fine. Problem is, after it turns on there are no visuals, the monitor won't kick on for anything, and my CAPS and NUM locks won't light up when pushed. HDD is spinning, as well as the fans.... and suggestions? i've tried pulling the HDD and the extra RAM. Could it be the OS? or is it probably my MOBO. Any suggestions and or links to other forums would be much appreciated.
     
  2. tMac85 macrumors 65816

    tMac85

    Joined:
    Sep 15, 2007
    Location:
    in a great place
    #2
    have you called apple?

    or take it to the apple store.
    sounds like you dont have apple care.

    problem sounds sketch. is it new? used? how long have you had it? did it work before?

    i guess some additional information is needed.
     
  3. Fonzijr1964 macrumors 68000

    Fonzijr1964

    Joined:
    Feb 26, 2008
    Location:
    Maryland
    #3
    try to reset the ram

    is the white light on the front on?
    if it is just press enter and it should start
     
  4. quest4apple macrumors member

    Joined:
    Apr 3, 2008
    #4
    Do you see the start-up sequence and then it goes blank, or do you never see anything at all?
     
  5. xlfodlx thread starter macrumors newbie

    Joined:
    Apr 12, 2008
    #5
    any help is appreciated

    It's not my computer so i'm not sure what was going on before this malfunction, sry. However, i have reseated the RAM several times, and in multiple different configurations... no luck there(makes me think it's the logic board). Also, no visuals what-so-ever, along with no 'chime'. Tried using just battery, just AC, and both. Tried reseting PMU, PRAM.
    (neither caps nor num lock light up, CD drive kinda ate my reboot disk, but fan and HDD are spinning, along with both the AC adapter and the computers light on.) thanks for any help... if you're going to tell me to call APPLE, or take it to them, just don't bother. I'm not in the business of paying good money for a P.O.S machine
     
  6. quest4apple macrumors member

    Joined:
    Apr 3, 2008
    #6
    How old is the machine? I assume AppleCare is expired? As for it being a P.O.S machine, it may be a simple fix, or are you opposed to the Macbook in general?

    Anyway, your original disc is in the CD-ROM? Have you tried starting up and pressing the Option key to try and boot from it?

    How about a second machine? Can you boot the second machine in FW target disk mode, connect the two, and try to start the Macbook off the other computer's system? That would eliminate the OS as the culprit.

    Or, can you start the Macbook in FW disk mode, connect it to another computer and access it's files?
     

Share This Page