i need help with installing apache server please!

Discussion in 'iPod touch Hacks' started by vegas-steven, Nov 14, 2007.

  1. vegas-steven macrumors regular

    Joined:
    Nov 14, 2007
    #1
    Hello,

    i want to install apache server on my ipod touch:

    I am a little over my head here. I got my touch just a few days ago, and usually i would just hide any sort of adult movies on the ipod classic under the music video category by telling itunes the file is a music video, not a movie.
    for some reason my touch will not play them this way, they dont play and freeze, but the files play when labelled "movie" so...

    i need to install apache on this device.

    I installed apache and PHP from the installer program.

    I then went into the tutorial on this site here:
    http://forums.macrumors.com/showthread.php?t=370793&highlight=ipod+touch+porn+hide

    Problem is that i dont know how to use terminal to do everything after step 2...
    i tried using terminal to ssh in.

    i went to my ipod, found my ip address, and tried to enter:

    root@address and cant access it. terminal tells me that access is denied at port 22.

    Can someone post those things on that page a little clearer? I plan on using this page and forum alot... and i do participate in these forums so i WONT JUST POST ONCE AND DISSAPEAR.... i know it is a community and we all help out.

    thanks alot.
    i appreciate it

    STEVEN
     
  2. madmaxmedia macrumors 68030

    Joined:
    Dec 17, 2003
    Location:
    Los Angeles, CA
    #2
    Have you installed SSH on your iPod Touch?

    If not, open Installer.app, and then install 'OpenSSH'.

    You can't sFTP into your Touch until you have SSH up and running on your Touch.
     
  3. Maegulimavri macrumors newbie

    Joined:
    Nov 17, 2007
    #3
    thats funny, i have been ssh-ing for a few days now without even knowing what the hell OpenSSH was, all using Cyberduck. Though, i have had problems uploading files larger than a couple of MB, getting a 'SSH stream was unexpectedly ended' error — am trying to install openSSH now, see if it helps.

    CHeers
     
  4. Maegulimavri macrumors newbie

    Joined:
    Nov 17, 2007
    #4
    OK, i installed OpenSSH. It did not alter the functionality of my SSH-ing to with CYberduck such that i am still unable to upload files larger than about 2 to 3 MB.

    And yes, i am certain that i did not already install OpenSSH. Strange?
     

Share This Page