I need help with my iPhone 3GS 4.0 OS

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Adaps, Apr 18, 2010.

  1. Adaps macrumors newbie

    Joined:
    Apr 18, 2010
    #1
    I currently am running OS 4.0 on a 3gs. My good friend is a developer so he kindly updated my iphone on his mac to 4.0. I have a winxp, and i found out i am not able to backup my iphone without the SDK 4.0 which i cant run on xp. I really need to backup because my friend tells me, come wednesday the beta will be updated and if i dont update my 4.0 beta my iphone will be locked? I am not sure if this is true, but if it is i was wondering if there is a way i can update it on his mac without erasing all my data, or is there a way i can downgrade back the hated 3.1.3. Thanks
     
  2. robivy64 macrumors member

    Joined:
    May 29, 2004
    Location:
    Fort Worth, TX
  3. gdlcjr macrumors regular

    Joined:
    Dec 3, 2009
    #3
    This is what people get when they cannot wait. :(
     
  4. Adaps thread starter macrumors newbie

    Joined:
    Apr 18, 2010
    #4
    thanks you guys are a great help. but seriously will my phone b locked or not?
     
  5. dejo Moderator

    dejo

    Staff Member

    Joined:
    Sep 2, 2004
    Location:
    The Centennial State
    #5
    Yes. Restore your phone and then at some point you'll be asked if you want to restore your backup. Say yes.
     
  6. Adaps thread starter macrumors newbie

    Joined:
    Apr 18, 2010
    #6
    To restore all i have to do is 'shift' click restore with the 3.1.3 firmware and thats it?
     
  7. ozzyman500 macrumors 65816

    Joined:
    Feb 4, 2009
    #7
    No, you will have to do several other steps after getting an error in iTunes. Which is why you shouldn't mess with beta's unless you're a developer or have a second device.
     

Share This Page