I Need OS X 10.5 to Sync My 3G iPhone?

Discussion in 'iPhone' started by MacMonkey13, Oct 5, 2010.

  1. MacMonkey13 macrumors member

    Joined:
    Jun 29, 2008
    Location:
    Gurnee, Illinois
    #1
    My three year old MacBook running 10.4.11 was not able to recognize my iPhone for its weekly sync. As I have had to do in the past, I uninstalled iTunes and attempted to reinstall it. To my surprise, the iTunes download said I needed OS X 10.5 to download iTunes.

    Seriously?

    Isn't there a way to download the current version of iTunes without getting Leopard or Snow Leopard? My iPhone is a 2 year old 3G and I can't update it anymore?
     
  2. Interstella5555 macrumors 603

    Interstella5555

    Joined:
    Jun 30, 2008
    #2
    While it's true that iTunes 10 is OX 10.5 only, I'm not sure that you ould be blocked from syncing and using your phone unless you upgraded to SL. I think you'll be able to DL a previous version of iTunes here; give it a shot.
     
  3. MacMonkey13 thread starter macrumors member

    Joined:
    Jun 29, 2008
    Location:
    Gurnee, Illinois
    #3
    Thanks, but the link appears to only have the Windows versions. I can't find the Mac versions.
     

Share This Page