I need to disable a2dp in Mavericks

Discussion in 'OS X Mavericks (10.9)' started by rezwits, Nov 15, 2013.

  1. rezwits, Nov 15, 2013
    Last edited: Nov 15, 2013

    rezwits macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #1
    How can I disable a2dp, bluetooth media playback etc. in Mavericks on MacBook Air.

    These tips like this:

    http://musings.silvertooth.us/category/macfixes/

    end up giving :

    defaults read com.apple.BluetoothAudioAgent
    Domain com.apple.BluetoothAudioAgent does not exist

    I was thinking I might be able to turn off a2dp using that line but not working.

    Here is the reason why I need this:

    I connect my bluetooth headset with multipoint to my iPhone
    I connect my macbook to the headset and then it disconnects
    it tries to reconnect over and over but then I turn off bluetooth

    REVERSE

    I connect my bluetooth headset with multipoint to my MacBook
    I connect my iPhone to the headset and then it connects, but

    The iPhone will not play music thru the headset only the MacBook
    it's like the a2dp streaming is pulsing keeping the handshaking going.

    Cause the iPhone cannot invoke the music to play via a2dp only the MacBook.

    What I want to do is, connect the MacBook to headset then disable the a2dp
    then connect iPhone to headset. This should work.

    or REVERSE (with prep)

    Connect MacBook to Headset, disable a2dp.
    disconnect MacBook
    Connect iPhone to Headset
    Connect MacBook to Headset

    if I can just turn off a2dp on the MacBook I should be able to go.

    The only other option would be find an app for iPhone that with force a2dp to get back into action while connect, BECAUSE I can make phone calls with the headset and siri etc when both are connected. Just can't get a2dp to work with iPhone while both are connected?

    Any clues?? or help?? or Apps?

    Thanks

    oh p.s. I googled for 2 hours...
     
  2. rezwits thread starter macrumors 6502a

    rezwits

    Joined:
    Jul 10, 2007
    Location:
    Las Vegas
    #2
    I tried the BT Explorer

    I tried the BT Explorer from developer.apple.com

    No go! Sucks...
     
  3. itailu macrumors newbie

    Joined:
    Dec 9, 2013
    #3
    fixed this

    Installed the app via Parallels.
    disabled the a2dp

    :)
     

Share This Page