i Phone could not be restored error message (1604)

Discussion in 'Jailbreaks and iOS Hacks' started by Tuckmonster, Jun 24, 2009.

  1. Tuckmonster macrumors regular

    Joined:
    Dec 16, 2007
    #1
    why am i getting "iPhone could not be restored. An unknown error has occured(1604)" everrytime i try to restore? please help me
     
  2. Enigmafan420 macrumors 6502a

    Enigmafan420

    Joined:
    Apr 18, 2008
    Location:
    Puget Sound, U.S.A.
    #2
    The only way I was able to overcome this was to use an entirely different Mac (thanks Dell mini 9 hackintosh :) ) to restore.

    Not even sure why that worked, but I downloaded the 3.0 on the dell mini 9 and then restored using itunes from there. Then JB on my "regular" mac.
     
  3. sinsin07 macrumors 68030

    Joined:
    Mar 28, 2009
    #3
    Wirelessly posted (Mozilla/5.0 (iPhone; U; CPU iPhone OS 3_0 like Mac OS X; en-us) AppleWebKit/528.18 (KHTML, like Gecko) Version/4.0 Mobile/7A341 Safari/528.16)

    From what I have read this 1604 is related to the USB port. the same issue happened when I tried to upgrade one of my 3g phones. Try removing all USB devices except iPhone cord.
     
  4. dhlizard macrumors G4

    dhlizard

    Joined:
    Mar 16, 2009
    Location:
    The Jailbreak Community
    #4
    It has been my experience that sometimes you get this message if you are trying to use a different IPSW than the correct one for whatever version of software is on your phone.

    Example, if you updated to 3.0, but are trying to downgrade to 2.2.1 or
    if you are trying to restore to custom restore IPSW


    However, sometimes I agree that this is computer specific (as previous poster indicated)
     

Share This Page