i really need help jb'ing a 1.1.3 ipod...

Discussion in 'iPod touch Hacks' started by vegas-steven, Mar 2, 2008.

  1. vegas-steven macrumors regular

    Joined:
    Nov 14, 2007
    #1
    Hello,

    a friend of mine has a 1.1.3 ipod that he wants to jailbreak... so much that he wants to PAY me for it lol.

    anyhow, it is a 16 gig version. i have tried the 1.1.4 on a risk that it MIGHT work, but that bricked it. i can restore to 1.1.3 but NOTHING ELSE (all other firmwares say that an unknown error has occured in itunes 7.6)

    can someone point me to a reliable place to guide me thru this?

    He just HAD to get a 16 gig touch, right? my 8 gig went to 1.1.3 jailbreak just fine.

    Anyhow, please help!
     
  2. bdsmyth macrumors regular

    Joined:
    Nov 3, 2007
    #2
    I've seen posts like this before here, try downgrading to (or installing) iTunes 7.5, it should be available on the net and starting again.
     
  3. PMB macrumors 65816

    PMB

    Joined:
    Nov 7, 2007
    Location:
    New York
    #3
    H'okay, so here is how you do it.

    PART A (FOR MAC OS X) - GETTING THE FIRMWARE FILES

    1. First, let’s get a copy of the version 1.1.1 firmware file using the Terminal.app. Yes, no funky Safari or even Firefox. The faithful Terminal.app provides the best error-free download. To download, launch Terminal, and then copy & paste the following long-line of text into your Terminal (it looks like this.) Hit Enter to start.

    curl http://appldnld.apple.com.edgesuite...70927.p23dD/iPod1,1_1.1.1_3A110a_Restore.ipsw -o iPod1,1_1.1.1_3A110a_Restore.ipsw -#
    If the process abort for whatever reason, make sure you delete the incomplete file from your Home folder first before you try again.
    2. You can Quit the Terminal once the percentage progress indicator shows 100%. The firmware file is now in your Home folder.
    3. OK, we need the version 1.1.2 firmware file as well, so let’s repeat the process with the following long-line of text:

    curl http://appldnld.apple.com.edgesuite...071107.9g3DF/iPod1,1_1.1.2_3B48b_Restore.ipsw -o iPod1,1_1.1.2_3B48b_Restore.ipsw -#

    PART A (FOR WINDOWS) - GETTING THE FIRMWARE FILES

    We’ll need both the version 1.1.1 and 1.1.2 firmware files. So let’s download them using Internet Explorer (or your favorite browser):

    Firmware version 1.1.1 - Download (Exactly 157,906,686 bytes)
    Firmware version 1.1.2 - Download (Exactly 165,567,897 bytes)

    The resulting files should be named “iPod1,1_1.1.1_3A110a_Restore.ipsw” and “iPod1,1_1.1.2_3B48b_Restore.ipsw” respectively. Do not decompress or manipulate them in any way, such as allowing your anti-virus/ anti-spyware/ anti-mac program to clean/billgatize the downloads. Double-check the file size before you proceed any further.

    PART B - GETTING READY TO JAILBREAK TO 1.1.1

    iTunes 7.5 for Mac OS X users is recommended, while Windows users can use either iTunes 7.5 or 7.6.

    Mac OS X users: If you’ve upgraded your Mac OS X’s iTunes to version 7.6, you’ll need to download and use the iNdependance app later on, or downgrade your iTunes to version 7.5. *[Feb 28 Insert] You’ll need iNdependence 1.4 Beta 5 if your iTunes is version 7.6.1.

    (Feb 13 Insert) Please temporarily disable your anti-virus/anti-spyware and any other programs that may interfere with the jailbreaking process. Do you have 3rd party programs that accesses iTunes in one way or another, such as AudioScrobber, lyrics fetcher, album cover downloader, sound enhancer, driver for your special sound card, etc? Disable all of them! Also, pull out to disconnect all usb devices except for the mouse and keyboard. Maybe reboot your PC to get it into a clean state first too.

    1. Connect your iPod touch to your computer. Make sure it shows up in iTunes.
    2. Put the iPod touch in DFU (Device Firmware Upgrade) Mode as follows:
    * Press and hold-down both the Power and Home buttons.
    * Release the Power button when you see the iPod disconnects and disappears from iTunes. This takes place in about 10 seconds. The iPod’s screen is blank.
    * Release the Home button when you see this (or this) pop-menu message, and click on “Check” (or “OK”). The ipod touch’s screen is still blank. Next, this popped up. Click on “OK” to continue. You should see your iPod touch in your iTunes round about now.
    * Press and Hold the Option Key (the SHIFT key for Windows) and click on the “Restore” button. Then select the firmware 1.1.1 file you just download in PART A, and let the restoration begin!
    3. Unlock the iPod and go to Settings and setup your Wifi, making sure HTTP Proxy is Off.
    4. Now go to Settings -> General -> Auto-Lock and set it to “Never”.
    5. In iTunes, be sure to set it up as a new iPod, un-tick the option to “Automatically sync songs to my iPod”, and “Open iTunes when this iPod is connected”. Click “Apply” and “Sync” to finalize the options you just set.

    Feb 12 Insert: Failure to carry out above seemingly trivia instructions and you will experience a Keyboard Freezing issue that renders your jailbroken iPod touch pretty much useless.

    6. Launch your iPod touch’s Safari, and surf to http://jailbreakme.com/.
    7. Scroll to the bottom of the page, and you’ll tap on the “Install AppSnapp” link. Your Safari will load the link, and suddenly freak out and your iPod touch returns to the Springboard. Done right, you will see a spinning wheel download progress indicator (it looks like this) while your iPod touch downloads and installs AppSnapp in the background. If you don’t see the indicator (within no more than 2 seconds after tapping the said link), re-apply this step until you do! Yes, keep on trying…, and trying…, and trying…. Depending on connection quality, sometimes it took me well over 4-5 tries before the indicator appeared! Some users report trying over days. That’s right, days! But of course, if conditions are right, you’ll get it on the first attempt. My best advise is to have a good internet connection, and perhaps try again at odd hours. Properly done, you’ll see in your Springboard a new icon named “Installer”. Your iPod touch has been jailbroken to version 1.1.1!



    PART C - JAILBREAK TO 1.1.2

    1. The Installer App is now in the Springboard. Tap on it, and go to the “Sources” tab to install the “Community Sources” package. After that, go to the “Tweaks (1.1.1)” category and installed “OktoPrep”. Quit Installer after installing it.

    Valentines’ Day Insert: If you can’t find OktoPrep in above, then add the following new source to your Installer:
    Installer->Sources->Edit->Add: http://hackthatphone.com/1.xml->OK->Done->Refresh
    You’ll find it in the “Hack that Phone tools” category after adding the new source.

    2. Go back to iTunes, then press and hold the Option key (SHIFT key for Windows) and click on the “Update” button (and not the Restore button you click on a short while ago!), then select the 2nd firmware file, iPod1,1_1.1.2_3B48b_Restore.ipsw, that you downloaded earlier in PART A.
    3. Restoration begins and not surprsingly went through without a hitch too.
    4. Your iPod touch will reboot and reconnects to iTunes. Do dismiss iTunes’ prompt to Update to version 1.1.3!
    5. Next, go download the Jailbreak.zip from Conceited Software to the Desktop and unzip it. At this point, it’s critical to QUIT iTunes while keeping the iPod touch connected to the computer. I repeat, Quit iTunes but keep iPod touch connected.
    6. Look inside the 1.1.2-jailbreak folder, and double click on “jailbreak.jar” for Mac OS X (or “Windows.bat” if you’re on Windows).

    Feb 24 Insert: Attention PC Users: You need Java to run Windows.bat. If your Windows doesn’t already have Java, you can go here and choose to download and install “Windows XP/Vista/2000/2003 Online * filesize: ~ 7.1 MB”.

    7. Do not tick “Install SSH”, and leave the password as “alpine”.
    8. Jailbreaking will take place right after you click on “Jailbreak”.
    9. When it’s done, your iPod touch will reboot twice, or more. Do NOT touch it during this period. You’ll unlock it if about 2-3 minutes has passed and the iPod touch has fallen asleep.



    Attention Mac OS X iTunes 7.6 Users: Your iPod touch after rebooting will be stuck at the Recovery Mode screen. Your iTunes 7.6 will want you to restore it. Don’t!

    Mount the iNdependence .dmg you downloaded earlier. Double-click to run the iNdependence.app and just sit back and watch your iPod touch. iNdependence will kick your iPod touch out of Recovery Mode and brings it to the Unlock Screen. Yippy! You can quit and trash iNdependence after that.

    10. Go to Settings -> General, and you’ll see it’s firmware 1.1.2… and the Installer app is in the Home screen.



    PART D - JAILBREAK TO 1.1.3

    As of today there are a number of methods to jailbreak to 1.1.3. In my opinion, the correct method is the Official Dev Team method.

    Best of all, Conceited Software (maker of AppSnapp, OktoPrep and Jailbreak.jar you used earlier) has provided an installer package to easily upgrade your 1.1.2 jailbroken iPod touch to version 1.1.3. It’s a long process, but there’s a nice GUI (Graphical User Interface) that tells you what’s going on.

    Let’s do it.

    1. If your ISP requires proxy, go to Wi-Fi settings page to update it.
    2. Launch Installer, go to the “Sources” tab, and tap on “Refresh” button. After that you’ll see that a new Installer version 3.0 is available. Update it and exit Installer. Feb 23 Update: Ignore that; current version 3.0 is already installed.
    3. Tap on Installer again, and in the “System” category, select and install the “BSD Subsystem” package. (If you don’t see this package, then go to the “Sources” category, and install the “Community Sources” package. After refreshing your sources, the “BSD Subsystem” package will show up.)
    4. After installing BSD Subsystem, it’s mission critical that you power-down and re-start your iPod touch.
    5. Do it now (by pressing and holding the power button until the red-slider appear….)



    Advanced Users Only: You’ll want to install the OpenSSH package at this point too if you plan to perform a time-saving trick outlined in the next black box below.

    6. Are you sure you have rebooted your iPod touch? OK, launch Installer and go to the “System” category and install the “Official 1.1.3 Upgrader” package. As of writing, it’s version 1.1.3-3. The “Contact” info is Conceited Software. It’s only 453.4 KB in size!

    Feb 15 Insert: CAN’T FIND OFFICIAL 1.1.3 UPGRADER? Some of you can’t find the package in the System category yesterday. Please try again. A new Community Source package is out and you should always update your apps and sources. After that the Upgrader should re-appear.

    Feb 17 Insert: Here’s a new source for the Upgrader. After adding the source, you can find it under the “iSpazio Unlock Tools” category:

    http://repo.ispazio.net/

    7. After installing the Upgrader pakage, you will find a new icon named “Upgrade” in your Springboard.



    Tip for Advanced Users (Provided by CyberGreg of ModMyiFone.com)

    At this point, you can SSH into your iPod touch and upload a copy of iPod1,1_1.13_4A93_Restore.ipsw to /private/var/root/Media. Doing so, the Upgrade.app will be able to complete its task quicker, in “… about 10 minutes …”, as it doesn’t have to download the 1.1.3 firmware file from Apple.

    Footnote: CyberGreg claims 10 minutes total time spent. I suspect that includes opting out the restore option in Upgrade by tapping “No“. I spent in all 21 minutes without the mentioned Restore process. Maybe my Wi-Fi and/or 3Mbps broadband plan suxs.

    8. (Feb 11 Insert) Disconnect your iPod touch from your computer. Do it. Done? Sure?
    9. Tap on Upgrade to start upgrading. When you see this pop-up prompt, make sure you tap on YES.



    When the upgrade process is done, your iPod touch is jailbroken to 1.1.3!

    But it’s a long, boring but thankfully, fully automated process. Go do something else while that’s going on. Just make sure the process isn’t interrupted by anything… such as a poor Wifi connection, low battery… whatever.

    And if after the long wait you find your iPod touch reboots but enters and seemingly stuck in Recovery Mode, don’t panic. That happened to mine too. Just wait it out. It will self-reboot again, and you’ll see the familiar Unlock Screen afterwards.

    Attention PC users:

    If your iPod touch is seemingly stuck in Recovery Mode, go download iBrickr and run it. It’s reported that iBrickr can get your stuck iPod touch out of its misery and let it boot normally into the Springboard. You can trash iBrickr after that.

    A user feedback that rebooting his pc and running iTunes again kicked his iPod touch out of Recovery Mode. Try it.

    [Feb 24 Insert] Attention Mac Users: If your iPod touch is stuck in the Recovery Mode after completion of the Upgrade process, you can try using iNdependance to kick it out.

    PART E - INSTALLING THE JANUARY SOFTWARE UPGRADE

    Guess what, it’s been a while but we’re finally ready to wiggle!

    1. Launch Installer and add the following new source: http://madpike05.googlepages.com/repo.xml

    Be careful typing the url; iPod touch’s auto-capitalization feature insists on changing “.xml” to “.XML” unless you dismiss it.

    2. Refresh your Installer after that.
    3. Go to the “iPhone 1.1.3 Applications” category, and install “The iPhone 1.1.3 Apps” package.
    4. After installation and unlocking your iPod touch, you’ll be greeted by this pop-up window indicating your iPod touch’s icon can wiggle.
    5. You really own a jailbroken 1.1.3 iPod touch.

    Ea voila, 1.1.3 JB'd pod, hope this helps.
     
  4. vegas-steven thread starter macrumors regular

    Joined:
    Nov 14, 2007
    #4
    JUST SAW THAT HUGE HOW TO.
    I guess that was posted while i wrote this. thanks, and i will give it a try later on.


    yeah. i read after posting this that itunes 7.6 will not even attempt to install a firmware earlier than 1.1.3... bet that has to do with people wanting to downgrade and jailbreak.

    i will need to wait until later after work when i can boot into windows and install itunes 7.5 there. i use itunes 7.6 in os x and need to use os x for photoshop and my work.

    also -

    any proper proven method to use?

    i find that most of these procedures tell me to use okoto prep (or something like that) from community sources, but THAT FAILS TO DOWNLOAD FROM INSTALLER.APP
     
  5. vegas-steven thread starter macrumors regular

    Joined:
    Nov 14, 2007
    #5
    ok

    so my itunes is 7.6 i downloaded the independence app, and it is running. it asked for unzipped upgrade packages, whereas itunes wants the ipsw file... so where does this fit into the process as i cannot use itunes for this.

    thanks.
     
  6. PMB macrumors 65816

    PMB

    Joined:
    Nov 7, 2007
    Location:
    New York
    #6
    i think you have to have 2 copies, though i am unfamiliar with the mac approach.
    i did mine on a PC, worked fine...
     

Share This Page