iPhone I reinstalled Mobile Substrate, and still no apps in settings. EDIT: fixed!

Discussion in 'Jailbreaks and iOS Hacks' started by wildonrio, Dec 25, 2013.

  1. wildonrio, Dec 25, 2013
    Last edited: Dec 25, 2013

    wildonrio macrumors 6502

    Joined:
    Aug 15, 2008
    #1
    Everyone is saying that they can get by the outdated Mobile Substrate by just reinstalling it after every reboot, and then respringing. This isn't working for me though. None of my apps show up in the Settings app. What can I do?

    EDIT: fixed by uninstalling and then reinstalling Mobile Substrate.
     
  2. rick snagwell macrumors 68040

    rick snagwell

    Joined:
    Feb 12, 2011
    Location:
    oceanside, ca
    #2
    maybe some specs on what device?
     
  3. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
  4. WisdomWolf macrumors regular

    Joined:
    Apr 15, 2010
    #4
    I was having the same issue. Reinstalling preference loader seemed to do the trick. Although now I can't open stock apps like Safari or Mail, not sure if that's related or not, still trying to chase down the cause.
     
  5. Regal macrumors regular

    Regal

    Joined:
    Nov 7, 2010
    Location:
    Sweden
    #5
    I have the same problem on my iPhone 5 and reinstalling MS doesn't help.
     
  6. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #6
    Here's what you can do.
    Wait like the rest of us.
     
  7. dlmart2 macrumors 6502a

    Joined:
    Nov 2, 2007
  8. cyber16 macrumors 6502

    Joined:
    Jan 12, 2013
    #8
    I would suggest ANYONE with a jailbroken idevice at ios 7 just to jailbreak it and LEAVE it alone until all the tools & apps are updated.
    If you are having issues now due to being inpatient, take this opportunity to start fresh and jailbreak again and LEAVE it alone.
    If not you may find once the signing window closes you have a screwed up idevice and will find yourself with no other options then going stock.
    At this point this Jailbreak is nothing more than ROOT for the most part without an updated MS.
    Having a clean ROOT'ed idevice is what its all about.
     
  9. Jett0516 macrumors 6502a

    Jett0516

    Joined:
    Mar 5, 2010
    #9
    Try killing the settings app first and then reinstall mobile substrate.
     
  10. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #10
    Others are having success by reinstalling mobile substrate. I am not, hence the question. It looks like I'm not alone.
     
  11. alkalifly macrumors regular

    alkalifly

    Joined:
    Apr 13, 2004
    #11
    Definitely not alone (using a 5S here). Fortunately, f.lux is my one essential tweak, and it has a springboard app so does not require access from the settings app, so I'm just holding tight until the MS update.
     
  12. oplix macrumors 65816

    oplix

    Joined:
    Jun 29, 2008
    Location:
    New York, NY
    #12
    I reinstalled Mobile Substrate, and still no apps in settings


    This guy hit the nail on the head.

    The reason you are having issues is because you don't know what you are doing. People who have been in the jailbreak scene for a long time realize how things play out. The way they play out is the jailbreak is released and then you wait and keep waiting until things are slowly updated.

    How do you think ios7 would look if they just released it without open beta? Get some perspective .

    Hackers in the jailbreak scene are happy enough with file system write access.
     
  13. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #13
    Been jailbreaking since 2007. I know what I'm doing. I only bring this up since some people are successfully getting apps to show up in Settings right now. I want to know how they are doing that. It's not a "Just wait for it" thing.
     
  14. Explicitic macrumors 6502

    Joined:
    Oct 26, 2012
    Location:
    Undecided
    #14
    Install the MS Reload fix tweak from the http://devbug.me/apt/
    It's an unofficial patch to MobileSubstrate which fixes the issue of settings disappearing after a reboot. It apparently just makes sure MobileSubstrate actually starts up on boot.
     
  15. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #15
    Thank you very much for actually trying to help instead of telling me I don't know what I'm doing! I really appreciate your suggestion. For the record it did not work; I still see nothing in Settings no matter what I do. I bet it will help others though.

    Anyone have another idea? Would redoing the jailbreak offer any possible benefit?
     
  16. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #16
    I fixed my problem by completely uninstalling Mobile Substrate and then reinstalling it. Good luck anyone else looking for this information!
     
  17. thieverycorp., Dec 25, 2013
    Last edited: Dec 25, 2013

    thieverycorp. macrumors regular

    Joined:
    Jun 19, 2010
    #17
    It works, but some things won't work either way. I installed KillBackground7 and it worked at the beginning but then I had the same problem and reinstalled MobileSubstrate and it is visible in the Settings app, but it won't work.
     
  18. wildonrio thread starter macrumors 6502

    Joined:
    Aug 15, 2008
    #18
    Well I fully expect things not to work. I was just jealous that others were able to see apps in Settings and I wasn't. Now we just have to wait for updates to apps.
     
  19. bobright macrumors 601

    Joined:
    Jun 29, 2010
    #20
    If you don't know what you're doing obviously you don't as you've hit a bump here, sit back and wait like everybody else.
     

Share This Page