I think I am f-ed...Mac Book Pro Bootcamp problems

KamikazeH20mln

macrumors newbie
Original poster
Aug 16, 2006
11
0
I have a MacBook Pro that previously had Bootcamp on it, and after testing, I went back to OS X only testing, wiping the Bootcamp partitions. Now I am done that testing, I wish to go back to bootcamp.

Problem is that with a single new partition, I can install Bootcamp, but not run it. It complains that "needs updated firmware". I check my about, and I am at Boot ROM Version MBP11.0055.803 and SMC Version 1.2f10.

I've tried Firmware Restoration CD from Apple, but that doesn't work cause the previous firmware flash was successful. I've tried the recommended MacBook Pro (early 2006) Firmware Update 1.0.1, but it complains that my firmware is already up-to-date and fails to run. I've also tried to do Option key hold at boot and install Win XP, but it only wipes out the Mac partition.

Any thoughts or suggestions on what to do next? Or am i just f-ed?
 

balamw

Moderator
Staff member
Aug 16, 2005
19,368
974
New England
KamikazeH20mln said:
I have a MacBook Pro that previously had Bootcamp on it, and after testing, I went back to OS X only testing, wiping the Bootcamp partitions. Now I am done that testing, I wish to go back to bootcamp.
Did you just empty/delete the BC partitions or is your disc actually back to a single partition? (i.e. what was the process you used to "wipe the partitions").

If the space is still there you should just be able to stick in the XP install CD and hold down option during boot to perform a new install. You don't actually need bootacamp unless you want to repartition the disc.

B
 

MRU

Suspended
Aug 23, 2005
25,318
8,706
Other
If you just wiped your partitions the chances are you've fecked your partition table into the standard apple partition scheme, whereas intel macs with bootcamp need guid partition scheme

Run disk utility, click partiton, choose options. if apple partition map is selected then thats a problem, you need to choose guid.
 

KamikazeH20mln

macrumors newbie
Original poster
Aug 16, 2006
11
0
diskutil list shows:

Code:
0: GUID_partition_scheme           *93.2GB  disk0
1:                  EFI            200.0MB  disk0s1
2:            Apple_HFS Mac OS X    92.8GB  disk0s2
I am basically back to a single partition. I did a wipe of the whole partition table from OS X install diskutil before when creating the multi boot mac OS X table and this time did the same thing to a single partition.