I think I just killed my G4 - help! (Powerlogix upgrade)

Discussion in 'Mac Basics and Help' started by NickFalk, Sep 29, 2005.

  1. NickFalk macrumors 6502


    Jun 9, 2004
    I'm not quite sure what my good old G4 733Mhz quicksilver did do deserve all the abuse I've been giving it. After a brush with death (well, the data on the HD's had one anyway) I think I finally murdered it once and for all!

    Having done all the easy stuff like replacing harddrives, CD-ROM, memory etc. I had the brilliant idea that a processor-upgrade was just the thing. I therefore ordered a Dual 1,6 Ghz upgrade from Powerlogix/OWC. Being the cautious kind I read the instructions thoroughly, checked that the Firmware was OK and proceeded to install the card as instructed.

    I re-connected the 'puter.. and nothing happened. Well, the fans started blowing, there was some sound from the HD's but no chime and no image on the screen. I disconnected the machine and tried to see if there was anything wrong with my work but everything seemed OK. I tried using the reset-switch inside the machine but to no avail.

    Really starting to sweat I decided to try and refit the machine with the original 733Mhz G4, fan and heatsink. The machine reacted like it did with the Powerlogix card, that is it didn't react at all!

    If anyone can sort this out for me I would be eternally gratefull!
  2. FoxyKaye macrumors 68000


    Jan 23, 2004
    Livermore, Terre d'Ange, Bas Lag, Gallifrey
    Couple longshot ideas...

    Any chance there's a short on the MoBo? It could be caused by a dropped or misplaced screw. Also, when you took the clip off of the heat sink, was there any chance that your screwdriver scraped the MoBo?

    A friend of mine lost her G3 B/W because one of the metal screws from the lever that opens the side of the machine worked its way out and fell behind the MoBo - next time she started it, the screw shorted the MoBo and that was the end of her G3.

    I wrecked a MoBo doing a processor upgrade once because when I used the screwdriver to pry the clip off of the heat sink, the edge of it dinged the MoBo - I had to look real close, but found a scratch that destroyed the connection on one of the tiny capacitors/resistors that were around the processor.

    Both times, the systems presented similar symptoms as the ones you're describing. Check behind the MoBo and see if there's anything back there, use a magnifying glass around the areas you're working and see if there's any scratches or dings.

    There may also be a chance that you've installed incompatible memory - sometimes Macs won't boot if there's the wrong RAM installed. Try putting back your old RAM and powering up again.
  3. DarkNovaMatter macrumors member

    Aug 3, 2001
    This might not fix your problem but, from what it sounds like, you might need to install their firmware patch for the card (most of the cpu upgrades require this). The thing is that the firmware patch must be installed before you put in the new processor (or else it won't boot, nothing on the screen). Also if you want to boot into OS 9 (don't know if you want to) you have to remove an extension in the multiprocessor extension folder, they should have all of this on the cd manual that came in the box. The one thing I am not sure of is when you put back the old 733 card why it acted the same (did you check all of your connections? card seated properly?) If everything seems ok (be sure to check and test) you might want to contact their tech support.

    P.S.- you might want to check about the power supply unit on your tower
  4. NickFalk thread starter macrumors 6502


    Jun 9, 2004
    Thanks guys. All sorted now. I had been reading the manual for a different upgrade card (ramming head into wall) and was under the impression I didn't have to upgrade the firmware.

    The old G4 wouldn't boot since I hadn't fastened all the screws(!)
    Well, you live and learn, that's for sure. :rolleyes:

Share This Page