I think I just killed my G4

Discussion in 'PowerPC Macs' started by rooster676, Apr 4, 2009.

  1. rooster676 macrumors newbie

    Apr 4, 2009
    Ok I was an idiot. I was installing new RAM, and noticed how dusty the inside of my G4 Mirror Drive Door was, so I vacuumed. I know this is risky, but I had done so in the past and it was fine, and plus I was out of compressed air. well, I must have been a little too careless because when I plugged it back in and tried to start it, I got nothing. The power button illuminates when I press it, but goes out when I let go. There is no click, nothing.

    Have I fried my electonics? can this be repaired? if now, how do I retrieve my data from my hard drive? (luckily, most has been backed up, but now all)

    I definitely want to get all the info I can before taking it in to get looked at and or repaired-just so I don't get sold any services that will not be worthwhile.

    If anyone can help, I'd be most grateful!


  2. mcavjame macrumors 65816


    Mar 10, 2008
    phased to this universe
    Before panicking, I would make sure your new RAM is seated properly. You might want to go back to the original RAM and check to ensure the new RAM is not the problem (correct type and capacity is accepted in your G4).

    If you did do something to the motherboard, it is unlikely your HD is toast. You could put it in a dock or enclosure and take it to another machine (or a friend's) and get your data backed up.
  3. kellen macrumors 68020


    Aug 11, 2006
    Seattle, WA
    That is a common problem with the MDD powermacs. Try unplugging the power cord, then replugging it in and trying to start it up.

    You may have to reset the PMU.

    Sometimes its a sign of the power supply going out, but would be very coincidental considering you were working on it.
  4. rooster676 thread starter macrumors newbie

    Apr 4, 2009
    Thanks guys-
    I did actually try re-installing the old RAM, and just went and re-checked it to make sure that it was properly seated in those slots-which they are
    and I've tried unconnecting and re-connecting the power cord, and nothing.

    so I think I'm screwed. in this case, would I need a new mother board and/or a new power supply?

    I am so sad for my G4-its been with me for 6 years and I'm kinda attached to it...

  5. AlexMaximus macrumors 6502a


    Aug 15, 2006
    A400M Base
    Do this..

    Hmmm.... I would not give up just yet!

    I have a G4 MDD as well and I think I had that before. As long as you don't smell some electronic burning or worse, there is little to worry.

    At first I would put every card out and inspect the connectors. Sometimes the are not shiny any more. Also sometimes you can damage (accidently)
    some pins inside the Ram slots. It happen to me... its kind of hard to describe how it looks but this is what I would do.

    Boot your machine with only one Ram in it. Assuming one ram bank has a bent pin, you do that with different Ram banks. Try different Ram configurations, meaning Slot 1 to 4.

    If it boots up you know which ram bank has connection problem. I would be absolutely be surprised if the reason of you problem is the PSU. I don't think so. Also reseat your graphic card. Don't give up.

    Let me know if that helped!

    Good luck
  6. rooster676 thread starter macrumors newbie

    Apr 4, 2009
    Thanks for the encouragement-but the problem is, it doesn't boot up AT ALL-
    When I push the Start button, It lights up, but nothing happens, and as soon as I let go of the button, the light fades.

    I just tried re-setting the PMU-nothing. I guess now I could try to take out the
    battery and leave it for awhile. but I'm not sure this would help either. I am pretty sure that I stupidly generated too much static while cleaning it
    (it was really dusty) and that is what did it
    so now, I am wondering, is it my power source thats fried? or my logic board?

    (if I had to choose, I would choos the PS, since this is less expensive)

    thanks again.

  7. Lucibelle macrumors member

    Mar 12, 2009
    It's strange that you're not getting any of the blinks or beeps that it does for certain problems/failures. I feel your pain, as static killed my G4 MDD, and I'd love to see it start up again. Mine beeps at startup, though. It's not a happy Mac.

    However, if it is the power supply, it's not necessarily a cheaper fix than the logic board, as the price has gone up due to more demand than supply. Here's a couple of power supplies for $500 with a trade-in of your old one, or $400 for a refurbished. Of course, this is assuming that the power supply is actually what's bad... You could actually replace the Mac (scroll down) for about the same or even less. It would just suck to replace the power supply, only to find you still have the same problem, and having diagnostics done on it isn't exactly cost effective, either.

    Found a cheaper power supply here.
  8. rooster676 thread starter macrumors newbie

    Apr 4, 2009
    Those are great links, thank you. The reason that I thought a logic board would be more expensive than a new ps was that all the ones I had found were like $600- but the ones you found are indeed in the same price range. so now, I am hoping that it would be one or the other, and not both.
    I guess I'll have to take it in to a Mac Tech-y person and pay the $99 bucks just to have them open it up and look. I'll have to then get the prognosis and go from there- if it is one of these though, I think I can just order the part and install. except this time I'll be way more careful.

    Then again, there is always the ultimate question-if I'm going to have to fork over serious cash, maybe I should just bite the bullet and upgrade to the Mac Pro. (this was part of my overall upgrade plan, but that phase wasn't supposed to happen til next year-this year was the laptop and upgrade to CS4-)
    I'll post the results of the diagnostics. Thank you everyone for your help

  9. JoeG4 macrumors 68030


    Jan 11, 2002
    Bay Area, Ca.
    Hit the PMU reset button, it's by the battery (IIRC).. uh.. maybe between the PCI slots, I forgot right now.
  10. kellen macrumors 68020


    Aug 11, 2006
    Seattle, WA
    Please do. I am battling the same thing with my dual 1ghz quicksilver. It will work fine after I unplug/plug in the cord, but I have to do this each time it is turned off.

    Rather odd. So far I have taken all the ram out, taken the graphics cards out, reseated the CPU heatsink, traded power cables, reset the pmu, tried a different battery. All to no avail.

    I would like to hear what your technicians have to say, although from my web searches it leaves most of them stumped and they recommend a new power supply or a new logic board.
  11. paul.opensource macrumors member

    Mar 8, 2009
    San Antonio, Texas

    Try this, it worrked for my G4 DA which exhibited the same symptoms:

    Unplug the Unit
    Remove the Battery
    Push the PMU reset Switch (count to 5 slow)
    Push the Power button on the front of the computer (count to 5 slow)
    Let the unit sit for 15-30 minutes
    Replace the Battery
    Plug it back in, and push the Power button

    Here is a support article on how to find the PMU reset: http://support.apple.com/kb/HT1939

    And the link I got this info from :

    Worked for my G4 DA after it was sleeping and the power in the house went out.

Share This Page