Resolved I think I killed my rMBP

Discussion in 'MacBook Pro' started by Vulcan, Jan 22, 2014.

  1. Vulcan, Jan 22, 2014
    Last edited: Jan 23, 2014

    Vulcan macrumors 65816

    Vulcan

    Joined:
    Jul 17, 2008
    Location:
    Pittsburgh, PA
    #1
    Hey guys,

    I have a rMBP, first generation still under AppleCare. Yesterday what happened was really bizarre. I clicked a link on Facebook that was linked to a tweet and my pointer changed into a beach ball and could not click anything. As a result, I shut down the computer and tried to restart it. When I started it, it would not make it past the screen with the gray Apple and spinning wheel.

    Preforming a safe boot did not work. Resetting the NVRAM/PRAM did not work. Repairing the disk and restoring permissions with disk utility did not work. Doing an archive and installing OS X again isn't an option because I can't get on my campuses Wifi within the restore utility (it needs an application to authenticate it). Is there anything else I should be doing?

    Thanks for any help in advance
     
  2. cvdb1969 macrumors newbie

    Joined:
    Nov 17, 2012
    Location:
    South Yorkshire, UK
    #2
    Two days ago I had a similar problem. I started up my RMBP (late 2013), but couldn't get beyond the spinning wheel. Save mode stopped 25% into the check, disk seems OK, permission repair didn't do anything. In the end I reinstalled OS X, which did the trick. Try to get a wifi signal or better an Ethernet connection and reinstall OS X. This will hopefully help. (In my case I have no idea what happened. I shut down the computer normally.)
     
  3. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #3
    You don't need to connect to your internet to test the hard drive.
    Boot to your Recovery partition (restart holding Command-R), then run Disk Utility, select your drive, and click Repair Disk (different from Repair Disk Permissions, which is unlikely to fix anything)

    You can then reboot into verbose boot mode (Command-V) which will display the various services that start when you are booting. It may be stopping at some particular service, and you can come back with what you find out.
    Be sure to be patient, as the boot after a forced shutdown may take several minutes - 20 minutes should be long enough to call it bad.
    (or, the Disk Utility may fix things, and the restart eventually is successful)
     
  4. Commy1 macrumors 6502a

    Commy1

    Joined:
    Feb 25, 2013
    #4
    I think I had a similar issue, but with my 2011 iMac.
    I'm not sure exactly what happened, but one morning I just tried to turn it on and bam, corrupt HD.
    I did exactly what was described, a fresh install of OSX which seems to have fixed it. After doing quite a few Disk Utility runs it came up with a system file corruption, seems kind of a random place for an issue on stable OS.
    The only culprit I may have is Disk Doctor, but this would be the first time I ever had any issue.
     
  5. MacDude21, Jan 22, 2014
    Last edited: Jan 22, 2014

    MacDude21 macrumors regular

    Joined:
    Jun 6, 2013
    #5
    I had a similar issue with a 2004 or something Mac Mini. It simply showed the spinning loading icon and the apple logo for hours and never booted. I had to do a fresh install of OSX.
    See if you can get into terminal and do ls , to see if your file system is even still there. Just plop you OSX install disk in, and it should be in some sort of "Applications" menu or something. It gives you a few basic programs including Terminal. You can also do cd (name) to enter a directory, and "\ " will do a space. cd .. will go to the enclosing folder. You can go and check around in your file system and see if your stuff is still on it. Then ask someone else for how to recover it, this is all I know.
    If it says permission denied do sudo ls and enter your admin account password when it asks. If you don't have a password on it then there is no hope for doing the command.
    If there is a file system
     
  6. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #6
    Sounds like a drive failure.

    It just happen to coincide with your click.
     
  7. Vulcan thread starter macrumors 65816

    Vulcan

    Joined:
    Jul 17, 2008
    Location:
    Pittsburgh, PA
    #7
    After repairing the disk for a second time, it started up after literally about 20 minutes and has been running okay ever since and starts at normal speed now. Thanks for everyone's help!
     

Share This Page