I think I've deleted Leopard for Windows XP - HELP!

Discussion in 'MacBook Pro' started by wasimyaqoob, Dec 19, 2007.

  1. wasimyaqoob macrumors 6502a

    Dec 23, 2005
    London, England.
    Hey Guys,

    I've just installed Windows XP Home using Boot Camp which came pre-installed on my Mac.

    However, it's installed Windows XP fine however it's removed Leopard.

    I'm on holiday at the moment and I've left my Leopard disc at home!

    I'm going to visit my Mac Store tomorrow where I am tomorrow, hopefully the Mac Genius can fix it.

    What do you guys think I should do?
  2. TimJim macrumors 6502a

    May 15, 2007
    If you re-formatted the whole drive then Leopard is gone.

    If you re-partitioned the hard drive into two parts (untitled 1 and untitled 2) and used untitled 2 as windows or something then it got deleted also.

    To double check hold option at start up
  3. Chuckypool macrumors member

    Aug 22, 2007
    Auckland, New Zealand
    Have you actually deleted Leopard or have you just set the default boot drive to be your XP partition?

    Try holding down option and rebooting - you should get a Mac OS X and an XP drive - select the OS X one and it should boot back into OS X (assuming of course that you haven't managed to delete the OS X partition).

  4. wasimyaqoob thread starter macrumors 6502a

    Dec 23, 2005
    London, England.
    Yeah you guys are right, only Windows is there as a partition.

    My Mac OS X Leopard has disappeared.

    What do I do in order to get Leopard back?

    I need your guys help - Thanks!

    Appreciate it loads!
  5. Jiddick ExRex macrumors 65816

    Jiddick ExRex

    May 14, 2006
    Roskilde, DK
    You start over. Install Leopard again and then boot camp. This time make sure you only format the smaller partition and not the whole drive when installing windows.
  6. Bearxor macrumors 6502a

    Jun 7, 2007
    With all the problems Leopard has caused me with my keyboard not working, it sounds like you did a great upgrade! :up:

    (sorry I couldn't resist)

Share This Page