I think Time Machine messed up my HD icon.

Discussion in 'macOS' started by Achiever, Jan 29, 2008.

  1. Achiever macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #1
    I have encountered an odd sort of problem that only occurred once I started using Time Machine (I didn't set it up for a couple of weeks after installing Leopard). A found a few similar, but not identical, problems on the Apple forums but the fixes offered there did not work. Here's my problem: ever since I set up and started using Time Machine, my Macintosh HD icon has changed and now matches the external drive's icon. (Screen grab attached). It's not an earth shattering problem by any stretch, but it is pretty annoying and confusing to not have the easy visual distinction. Any thoughts?

    BTW, the computer is an aluminum iMac, runs 10.5.1 and the external drive is an OWC Mercury Elite. Any help is appreciated.
     

    Attached Files:

  2. hodgjy macrumors 6502

    Joined:
    Apr 15, 2005
    #2
    I've actually heard of this bug once before on these forums. Hopefully, it will be fixed in the 10.5.2 update. In the meantime, you can try fixing the icon yourself my right clicking the icon and selecting "get info." The box that comes up has a picture of the icon. You should be able to click on it and then go to the menu bar and under edit, select cut. Or, you can drag your icon of choice on there to replace.

    You can always repair permissions and delete some plist preference files to see if that helps as well.
     
  3. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #3
    Sorry to duplicate the thread/topic. I looked for it elsewhere, but didn't find it. I am also hopeful that this is one of the 5.2 fixes.

    The Get Info/Cut fix was also mentioned on the Apple Forums, but this did not work for me. I am not able to Cut anything from the Get Info box (not an active option).

    As for copying the icon I want in its place, does anyone know where I can find the old HD icon either in OS X on on a freeware site? I don't want to have to pay for a replacement icon.

    I also tried repairing permission previously, but that didn't do anything, either. I am not familiar with the deleting .plist option you mentioned. Can someone shed some more light on what this is and how to do it? Many thanks.
     
  4. adamswick macrumors newbie

    Joined:
    Jan 29, 2008
    #4
    I had the same issue...

    ...but it has appeared to have fixed itself after I turned-off Time Machine and restarted.
     
  5. DukeofAnkh macrumors regular

    Joined:
    Oct 5, 2007
    Location:
    Melbourne
    #5
    If you just want to change the icon and don't so much mind whether it's the original icon, you could try downloading one you like from here: http://iconfactory.com/freeware/icon and changing to that.

    How to change:

    1. Open "Get Info" on both what you want to change the icon of and the icon you want to replace it with.
    2. Click on the icon just under the red x button in both Get Info panels.
    3. Drag the big icon (under the preview tab lower down in the Get Info panel) from the new icon over to the aforementioned small icon in the other Get Info panel. It should change. Sometimes it takes two or three goes, though.

    If you Google around, you might be able to find the original icon somewhere.
     
  6. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #6
    Once you started using Time Machine on again, did it alter the icon once again or was it a one time bug?
     
  7. richkent72 macrumors regular

    #7
    If cutting and pasting doesn't work in the get info screen, try deleting the icon instead. If you use a custom icon for a drive and do this it changes back to the default one. Of course, depending on what caused it to change in the first place, the 'default icon' might now be the incorrect one already showing.
     
  8. adamswick macrumors newbie

    Joined:
    Jan 29, 2008
    #8
    This was a one-time deal for me.

    Is it possibe that your main HD was set to be a backup volume at one time? I did find this to remove Time Machine support on a volume:

    sudo rm .com.apple.timemachine.supported
    sudo rm .0* (that's a numeric zero, not an oh, part of a hexadecimal string)

    I have not tried this myself.
     
  9. Achiever thread starter macrumors 6502

    Achiever

    Joined:
    Jan 23, 2008
    #9
    This seems to be the solution

    This worked! I turned off TM and shut down. On restart, I had my icon back. When I turned on my external drive (with TM still set to off) it came up in appeared on my desktop as an orange icon. When I switched on TM, the external drive icon switched back to green when TM saved the first backup. I then restarted the machine (TM on) and the HD icon was green again. This is the bug. It seems that if I turn off TM before turning off or restarting the machine, the HD icon remains intact. If TM is on while rebooting/restarting, the HD icon morphs into the same green icon as my external drive.

    Strange little bug. I hope 5.2 or 5.3 deals with it so I am not always having to turn off TM when I have to restart or shut down.

    Thanks for all of the assistance!
     
  10. anthony.gomez macrumors newbie

    Joined:
    May 15, 2009
    #10
    Here Is The Solution

    Just go to Time Machine...
    Change Disk...
    Click NONE.
    So that Time Machine is NOT assigned to any drive...
    Check desktop...DONE.
    HD Icon is back to normal!
     

Share This Page