I tried everything and still cant update to 4.3.3!

Discussion in 'iPhone Tips, Help and Troubleshooting' started by Nebul0us, Jun 6, 2011.

  1. Nebul0us macrumors newbie

    Joined:
    Jun 6, 2011
    #1
    hello. im not new to updating my iphone, jailbreaking and unlocking it, but i have no idea whats going on this time.

    i have iphone 3GS on firmware 4.2.1, with 06.15.00 Baseband (the ipad bb right?)

    i tried updating via itunes to firmaware 4.3.3 and it keeps saying "the iphone *** culd not be updated. this devise isn't eligible for the requested built". i read somewhere that this error is because my iphone has the ipad baseband, please corect me if im wrong. i also downloaded custom 4.3.3 firmaware and tried updating via itunes and again i got the same error. please help me, and tell me what should i do to be able to update. i really need to update because everything on my iphone keeps crashing. and this error is driving me crazy. thanks in advance.
     
  2. awadeee macrumors 68020

    awadeee

    Joined:
    Jan 21, 2011
    Location:
    Viper City
    #2
    You need to use custom 4.3.3 firmware and you have to be in pwned DFU mode. You can use redsn0w 0.9.6RC17 to get into pwned DFU mode.
     
  3. Nebul0us thread starter macrumors newbie

    Joined:
    Jun 6, 2011
    #3
    i already mentioned that i used a custom 4.3.3. doesnt custom mean that u download it over the net? i mean its not the one itunes tried installing for u. i still get same error with the custom fw.
     
  4. UngratefulNinja macrumors 68000

    UngratefulNinja

    Joined:
    May 9, 2009
    Location:
    Pennsylvania
    #4
    That's not what custom fw means.
     
  5. Nebul0us thread starter macrumors newbie

    Joined:
    Jun 6, 2011
    #5
    my mistake. may i please know how to get a custom fw then? and how to use it via itunes to be able o update?
     

Share This Page