I tried EVERYTHING... Error 6 restoring 2g Iphone after clearing all data.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by fbuchele, Apr 29, 2009.

  1. fbuchele macrumors newbie

    Joined:
    Apr 29, 2009
    #1
    Hi, in my Googling macforums appears to be the most helpful community with background and experience in fixing things, and I have an Iphone that's been nothing but trouble. I was wondering if you could help me with it?

    I have an Iphone 2G that used to have firmware 2.0 on it. It was jailbroken with Pwnage tools on a Mac computer. I first got the iphone fully jailbroken from a friend as a gift. It wasn't broken, he just didn't like it. First thing I did was go to the settings (on the iphone) and clicked 'erase all data and personal information.' That took about an hour or two...

    Then the problems started.

    It booted up to a picture of a pineapple with a bite out of it... And didn't do anything else. I googled around and tried to find different things to do. Eventually I found out how to put it into DFU mode (Press and hold power and home), and I downloaded a 2.2.1 version of firmware. My internet is extremely slow, (imagine dial-up speeds), so I used a direct download on a download manager. I put it into Itunes, did the shift-click restore to try to restore the 2.0 iphone from the 2.2.1 firmware. Needless to say, it didn't work (error 1601 I think). However, now the iphone boots up past the pineapple to a picture of... Bill Gates speaking Russian. :confused: I googled this, found out it was the Pwnage tools recovery logo.

    Fair enough, so I downloaded 2.2.1 a few more times (over the course of a day or two), and none of them worked. Through more research I found out simultaneously that you can only restore from the same firmware you had previously, and that many of the errors I was getting are a result of corrupted firmware. I found out a dirty way to check it; copy the firmware somewhere else, convert the tag from .ipsw to .zip, and unzip. If there are corruption errors, the firmware is corrupted. I downloaded several 2.0 firmwares from several different sites, and each had a different bit of corruption.

    I had a bright idea. Why not just combine the working parts into a Frankensteinian firmware? I took 3 different firmwares, unzipped them, and patched them together, using only the non-corrupt parts. I then zipped it back up, converted the tag to .ipsw, and tried it on my iphone in DFU and regular mode.....

    Didn't work, threw out an Unknown Error (1) both ways, right after 'extracting software', as soon as it begins 'preparing iphone for restore'. :mad:

    At this point, my only problem is corrupted firmware right and left. Unfortunately I'm never at an internet connection to download the software through itunes. I finally had the idea to download a .rar of the .ipsw, so I found a direct download on some Russian hacker site. I downloaded that, and unrar'd it, and it gave me another corruption error. Not to be deterred, I told it to keep broken files anyways, and got the software. I threw it through itunes and....

    Oh my god. My screen is doing something different. It unpacked software, prepared iphone, then went to 'restoring iphone software'. The iphone shows the good 'ol apple logo, and a spinning thing at the bottom. This continues until the bar is about 25% full, and then... Unknown error 6.

    I am almost tearing my hair out at this point. I've scowered the internet high and low for solutions, tried it on two different computers, several different cables and USB ports, I have the latest version of Itunes, I've tried using Pwnage tools 2.0, 2.1 on the mac and winpwn 2.2.1, 2.0, and 3.0. None of them even recognize that the iphone is even connected to the computer.

    Please help? :p
     
  2. fbuchele thread starter macrumors newbie

    Joined:
    Apr 29, 2009
    #2
    Bump/ Update

    On a hunch I checked out the firmware that i get the error 6 with, and sure enough... file corruption in 018-3785-2.dmg... I guess i'll have to keep redownloading over and over until I can get past this file corruption...
     
  3. fbuchele thread starter macrumors newbie

    Joined:
    Apr 29, 2009
    #3

Share This Page