I unlock my iphone 3g now it does not have service.

Discussion in 'iPhone Tips, Help and Troubleshooting' started by cnino1971, Jul 5, 2009.

  1. cnino1971 macrumors newbie

    Joined:
    Jul 5, 2009
    #1
    Hello guys, I had an Iphone unlock, but since I wanted to have the latest ware on my iphone I donwloaded the 3.0 ware and proceed to unlock my phone after the upgrade.

    Now my iphone is unlock with the 3.0 ware but it says "no service" I cant get any service from tmobile anymore. my wifi works fine and tried my sim card on my wife's iphone and it does work. her sim card does not work on my iphone either.

    Can someone help me how to set up the phone so it will work with tmobile again?

    thanks

    tron1971@gmail.com
     
  2. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #2
    Here's what to do:

    1. Back up your phone. Put the phone into DFU mode, iTunes will detect it. Let iTunes restore it to 3.0. This is how you do DFU: http://www.youtube.com/watch?v=ofpinyGlQ8I

    2. Jailbreak your phone with RedSn0w like this:
    - http://www.iclarified.com/entry/index.php?enid=4301 (Windows)
    - http://www.iclarified.com/entry/index.php?enid=4303 (Mac)

    3. If you want to unlock, unlock the phone with UltraSn0w like this:
    - http://www.iclarified.com/entry/index.php?enid=4253

    4. Restore from your backup.

    You should now be OK.
     
  3. lilolme5 macrumors newbie

    Joined:
    Jul 7, 2009
    #3
    I tried that & it still didnt work and I have the exact same problem.What am I doing wrong?
     
  4. impulse462 Suspended

    impulse462

    Joined:
    Jun 3, 2009
    #4
    have you disabled 3G in the settings->network category?
     
  5. taitofu macrumors newbie

    Joined:
    Jul 8, 2009
    #5
    Same problem - on Rogers

    Hi, I'm a newbie here, and to jailbreaking.

    I've had my iPhone 3g for a year now, and have decided to jailbreak. I've researched extensively, and have run into the following problems with no resolution.

    1) I have a 6 GB data plan with Rogers, and now my iPhone will not allow me to connect to the internet over 3G. I can not make phone calls.

    I CAN connect over wifi. After jailbreaking, it should work from my understanding, 3g, phone calls, and wifi, etc.

    The first time I jailbroke (redsn0w 0.7.2), I ran into this problem. So, I restored to factory settings, and re-followed the regular steps (now using redsn0w 0.8). No unlock was used.

    CAN SOMEONE PLEASE ADVISE AS TO HOW TO TROUBLESHOOT THIS PLEASE? THANK YOU.
     
  6. Moi un Mouton macrumors 68000

    Joined:
    Mar 18, 2008
    Location:
    Bracknell UK
    #6
    Just as a suggestion, restore again, check that it works, then run RedSn0w again to jailbreak and UltraSn0w to unlock. See if that makes a difference.
     
  7. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #7
    You MUST go into settings and turn the 3G off ( under "network")for it to run on T-Mobile USA.
     
  8. 8CoreWhore macrumors 68020

    8CoreWhore

    Joined:
    Jan 17, 2008
    Location:
    Big D
    #8
    Try turning "3G" off, which will then default to EDGE. That should give you voice calls and slower data. I'm just not sure about Canada - but try it.
     

Share This Page