I want my old iWeb back!

Discussion in 'Mac Apps and Mac App Store' started by slipper, Mar 30, 2009.

  1. slipper macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #1
    I posted this in the web design forum but i guess it would be better suited in this forum.

    Anyway, i do not like the new iWeb '09 and want the '08 version back. I have the install disc. When trying to install, it does not allow me to. Im assuming because i have a newer version already on my computer.

    So how can i get rid of iWeb 09 and install iWeb 08?
     
  2. BlueRevolution macrumors 603

    BlueRevolution

    Joined:
    Jul 26, 2004
    Location:
    Montreal, QC
    #2
    Just trash the old (new) iWeb.app and open your OS X install disks with Pacifist. Find the correct package and you're laughing.
     
  3. awpitchy macrumors member

    awpitchy

    Joined:
    Mar 28, 2009
    Location:
    Mac World
    #3
    Easy as 123!!
     
  4. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #4
    OK i got iWeb 08 on my computer but now i cannot open the webpages i have already created and im getting two error messages:

    The document "Domain" could not be opened.

    and

    iWeb cant open file "~library/application support/iweb/domain.sites2."
     
  5. claimjumper macrumors newbie

    claimjumper

    Joined:
    Dec 17, 2008
    Location:
    Florida
    #5
    The "domain" file is in:
    (your home folder)/Library/Application Support/iWeb

    you will need to replace the one from the '09 version with the older one from your backups.
     
  6. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
  7. smurfjammer macrumors 6502a

    smurfjammer

    Joined:
    Jun 7, 2004
    Location:
    Auckland, New Zealand
    #7
    Just move that folder to a different location (desktop), delete the old folder and open iWeb and it will create the required folder structure and just drop in the websites into that folder or drop and drag into the iWeb window.
     
  8. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #8
    Please explain in more detail.

    The "domain" file from iWeb '09 will not work with iWeb '08
     
  9. sickmacdoc macrumors 68020

    sickmacdoc

    Joined:
    Jun 14, 2008
    Location:
    New Hampshire
    #9
    If you don't have a backup copy of your domain.sites file before it was automatically upgraded to the 09 format, as claimjumper mentioned, then you will not be able to use iWeb 08 with that file since both the structure and content is changed when upgrading to 09. You are not really SOL though since you can use 09 with it fine- those people who destroy their domain.sites files or have harddrives crash without backup are the people that are truly screwed!:(

    I'm curious what problems you have run into though I must admit. I have a number of pretty involved sites and love 09 myself!;)
     
  10. slipper thread starter macrumors 68000

    slipper

    Joined:
    Nov 19, 2003
    #10
    I have time machine backups, but i have since did a few upgrades to the website.

    iWeb '09 just doesnt seem like much of an upgrade. The Colors output as RGB instead of hexidecimal code. And it outputs a color completely different. I've also noticed a weird glitch with text where sometimes it outputs with odd spacing.
     
  11. chinajon macrumors newbie

    chinajon

    Joined:
    Feb 16, 2006
    Location:
    China
    #11
    Forward, ever forward

    I have been struggling with iWeb 09 since I got it. Today it finally published! I think the problems were with the Apple servers or site.

    Anyway, the new iWeb is working.

    Thanks Apple!
    :rolleyes:
     

Share This Page