I want to flash a 4870, but I can't

Discussion in 'Mac Pro' started by mmadsen, Aug 27, 2010.

  1. mmadsen macrumors newbie

    Joined:
    Aug 27, 2010
    #1
    I have the following Mac Pro:
    MacPro1,1
    Dual-Core Intel Xeon
    9 GB RAM
    OSX - Snow Leopard 10.6.4 (with graphics update)
    Dell 2208WFP 24" monitor

    And I'd love to use the new XFX ATI Radeon HD 4870 (ZWFL) in it. I've been diligently trying to follow the guides and advice found here, but I'm getting nowhere, and I'm starting to wonder if I have a hardware problem.

    I installed the card into slot 1, and moved my GT7300 to slot 4. I plugged the power cables into the XFX. I was hoping I could flash it using Zeus, but when I turned on the Mac, and tried to boot to OSX, I got a grey screen of death saying "You need to restart your computer. Hold down the Power button until it turns off, then press the Power button again."

    Then I booted to Windows Vista (boot camp). The only way I could get GPU-Z to give me info on the card was to install Catalyst drivers, plug the monitor into the XFX card, and force boot camp to restart to Windows. Once Windows restarted, GPU-Z gave me all sorts of info, but will not save the rom. It says the BIOS won't let it save (I can't recall the exact error, sorry).

    Then I got ATIFlash 3.79, went to a command prompt, and typed "atiflash -i", and was disappointed when nothing listed.

    On the positive side, while I was in Windows using with the XFX card, I was able to play Supreme Commander, and it was silky-smooth.

    I've tried over and over, and I can't even get to a point where I can flash it. I've tried unplugging and removing all peripherals, including extra internal hard drives.

    Am I doing something wrong, or am I looking at a bad card? It seems from the messages here that it should be much easier than it's been so far.
     
  2. mmadsen thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #2
    Got it

    After no reply here, and a hell of a lot more reading on the message boards, I finally got the card to work. I thought I'd reply here in case some other newb runs into the same problems.

    Sometimes a card will cause the Mac to panic. It happens, and is not indicative of a hardware problem. Even though most of the how-to threads imply it shouldn't, there's a thread or two out there that say it does.

    Atiflash must be run from DOS. Period. I thought if I ran it in a Windows command prompt, even thought I was just trying to get info on the card and not flashing, won't work.

    Getting your Mac to boot to DOS is difficult. I first tried the UBCD tips, and ended up with checksum errors. I tried bootdisk.com images, and got an unresponsive keyboard. I never could get a USB flash drive to boot at all. What ultimately worked was a post somewhere that said that using MagicISO to make a UBCD caused the checksum error, and I needed to use UltraISO instead. Whoever wrote that post (I can't remember if it was even on this site), I owe you a beer, because that enabled me to finally get to a DOS prompt to flash.

    Once it was flashed, I had a hell of a time getting it to be Quartz Extreme enabled. I used Zeus, which was extremely useful for getting the graphics drivers, but didn't help at all when it came to getting Quartz to work. If you're running into this same problem, you need a few kext files installed. I found a thread that has links to mapp.zip and nvmapp.zip, which fixed everything. (This post here: http://forums.macrumors.com/showpost.php?p=10798478&postcount=87)

    I'm still unsure if I got everything right. Portal and Starcraft II run, although they are quite slow using "recommended" settings. Once I bumped down the resolution and texture details, they play OK. Warcraft III was blazing fast (the only app I could compare to my old GT7300). I'm inclined to think I'm running into slowdown due to my Mac rather than the video card at this point (MacPro1,1, dual-core). If that seems unusually slow, please let me know, and I'll resume searching the message boards for solutions.
     
  3. mmadsen thread starter macrumors newbie

    Joined:
    Aug 27, 2010
    #3
    Benchmark

    In case anyone wants to know, I ran Cinebench 11.5, and here's my results:

    Processor: Intel Xeon CPU 5150
    Cores x GHz: 4 Cores, 4 Threads @ 2.66 GHz
    OS: OS X 10.6.4
    CB Version: 64 BIT
    GFX Board: ATI Radeon HD 4870 OpenGL Engine

    OpenGL score: 22.97
    CPU score: 2.92

    Judging by the reference benchmark scores, it looks like I fit in the curve about right.
     
  4. apple_iBoy macrumors 6502a

    Joined:
    Oct 28, 2003
    Location:
    Philadelphia, PA
    #4
    Hi there — I appreciate that someone out there apparently had trouble similar to what I'm having now and was able to resolve it.

    I bought a PC XFX 4870 1GB. I followed the various instructions posted to download a ROM file and the flashing software.

    I have tried to do the flashing using ATIWinFlash in two different Boot Camp partitions — XP and Windows 7. Neither one worked. None of the various versions of ATIWinFlash would even bring up a window upon launching (although a process showed up in the task list for awhile and caused the machine to become unresponsive).

    I have also tried to duplicate the process described by Jacob Croft. It took me awhile to find a version of the Ultimate Boot Disk that included the OpenDOS environment he used, but I did finally find a link to the version pictured in his screenshots.

    When I use ATIFlash in the FreeDOS environment, the card is not recognized with the command ATIFlash -i. Also, nothing happens when I type ATIFlash -p 0 macxfx.rom -f . I just get a new command prompt in either case.

    This card is recognized and functioning in Windows 7. However, it kernel panics on the opening Apple screen if I try to boot in Snow Leopard.

    I'm kind of at a loss — any suggestions??
     
  5. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #5
    Thanks for putting these pieces together.

    Where did you get the ZWFL?
     
  6. apple_iBoy macrumors 6502a

    Joined:
    Oct 28, 2003
    Location:
    Philadelphia, PA
    #6
    mmadsen, did you end up using both mapp.zip and Ny mapp?

    I finally did get the card flashed. I made myself a new DOS boot disk. Oddly enough, I used exactly the same files (didn't even re-download them), and the new CD worked. Not sure what happen there.

    I've been able to boot in OS X finally, and I do see in Zeus that Quartz Extreme is not enabled (I ran the appropriate downloader in Zeus).

    When I've tried installing either of the replacement kext file sets, my screen becomes garbled upon reboot into OS X and I end up having to reset the machine. Did you run into any trouble like that?
     

Share This Page