I want to re-encrypt some drives, but I get an error message

Discussion in 'OS X Mountain Lion (10.8)' started by Siderz, Jul 14, 2013.

  1. Siderz, Jul 14, 2013
    Last edited: Jul 14, 2013

    Siderz macrumors 6502a

    Nov 10, 2012
    I encrypted some drives, then decided I didn't need such a long password, so I decrypted them, and now when I try to do step 1 (encrypt) it comes up with this error message:

    The drives are not encrypted, I can eject and mount them without any need to put the password in again.

    I encrypted them using Finder by just right clicking and clicking encrypt.

    I need this fixed very quickly.

    I also found this thread - https://discussions.apple.com/thread/5042006 - I did Linc Davis's steps, but there's nothing else in the thread afterwards.

    Edit: They're all external drives; not internal, not boot drives.
  2. opinio macrumors 65816

    Mar 23, 2013
    I find rebooting and reformating the drives helps. Try repartitioning in another format such as fat then retry HFS+ encrypted again. I use disk utility to encrypt.
  3. Siderz thread starter macrumors 6502a

    Nov 10, 2012
    It's the morning and I just tried it, one of the drives will encrypt, the rest won't. What was odd was that the drive appeared in a default space on my desktop as if it was a new drive, not in the place where I had put it.

    I can't just format the drives since they have a lot of my data on them and there's not enough time to copy that across. At least I've got the most important drive encrypted though.
  4. Siderz thread starter macrumors 6502a

    Nov 10, 2012
    Quick update, I decided to just leave the hard drives on, one of them ejected itself, then reset its position to the default location on my desktop (Like what happened to the first drive) and now I've managed to encrypt it again.

    One more drive to go, and I can do that one while I'm away. Looks like the problem solved itself then.

Share This Page