I would not recommend deleting Gmails using the Iphone Mail App

Discussion in 'iOS 7' started by petalino, Dec 7, 2013.

  1. petalino macrumors regular

    Joined:
    Nov 21, 2010
    #1
    Ever since I installed the latest IOS7 I am not able do just delete my Gmail emails by swiping to the left and clicking on Delete. I am talking about the Mail App, which is native to the iPhone itself.

    On previous releases it was plain and simple: swipe your finger over an email and choose DELETE.

    Now when I swipe my finger over an email, I can only select MORE or ARCHIVE, but there is no DELETE.

    Once I go into MORE, I can finally choose MOVE TO JUNK as the only option to delete a read email.

    Here is the problem: as I noticed, MOVE TO JUNK seems to mark the email in question as a SPAM mail. Consecutively, all following email from same sender are being seen by Google as Spam and they end up in the SPAM folder, being moved there by Google itself.

    Great way to lose important messages from people or customers you care about.

    Is anyone else having this problem?
     
  2. quickie14 macrumors newbie

    Joined:
    Apr 20, 2012
    #2
    No problems here, when I swipe left I get Trash and More options.

    You may need to check Settings > Mail, Contacts, Calendars > Select Account and check your advanced settings for Move Discarded Messages Into... As there is two options, one for Deleted Mailbox and the other is Archive Mailbox.
     
  3. samiznaetekto macrumors 65816

    Joined:
    Dec 26, 2009
    #3
    You cn restore Delete button in Settings/Mail/Account/Advanced... "Move discarded messages into Deleted Mailbox"
     
  4. joec1101 macrumors 6502

    Joined:
    Jun 29, 2010
    Location:
    So Cal, USA
    #4
    If I understand you correctly, you want to be able to swipe to delete, not archive, correct?

    If so, you can change this in your advanced mail settings. You can select to move discarded messages into either the deleted mailbox or the archive mailbox.
     
  5. Oz. macrumors regular

    Oz.

    Joined:
    Jan 20, 2011
    #5
    go to settings > mail > gmail account > account > advanced > select "deleted mailbox" on "move discarded messages into section"


    this will do the trick ;)


    the mail app is great you just have to know how to use it :)
     
  6. Bilalo macrumors 6502

    Joined:
    Aug 17, 2012
    Location:
    Oxford, England
    #6
    Its settings of ur gmail itself, same happens to me bcz my university mail which is gmail dsnt allow students to completely erase an email jst archive it. Dno how to change it though
     
  7. joshforman macrumors regular

    Joined:
    Aug 11, 2012
    #7
    What this guy said.

    Also FWIW, "junk" is what Apple has called spam in Mail.app for OS X for years.
     
  8. Xenc macrumors 6502a

    Xenc

    Joined:
    May 8, 2010
    Location:
    London, England
    #8
    You should still be able to permanently delete emails. Gmail just prioritises archiving.
     
  9. CTHarrryH macrumors 65816

    Joined:
    Jul 4, 2012
    #9
    I had to change settings in a native mail. went into browser and when into GMAIL and changed setting to delete rather than archive.
     
  10. charlituna macrumors G3

    charlituna

    Joined:
    Jun 11, 2008
    Location:
    Los Angeles, CA
    #10
    That is gmail's default. They want folks to archive, not delete. Just go in settings and change it
     
  11. Stalyn macrumors regular

    Joined:
    Jul 7, 2012
  12. takeshi74 macrumors 601

    Joined:
    Feb 9, 2011
    #12
    I'd recommend checking your settings before making such proclamations.

    Which should be expected.
     

Share This Page