i7 MBP wont load Mac boot drivers after boot camp

Discussion in 'Windows, Linux & Others on the Mac' started by FongMan, Jul 6, 2010.

  1. FongMan macrumors regular

    FongMan

    Joined:
    Feb 4, 2006
    #1
    Have the new 15" MBP with i7 Processor.
    I had another MBP with a 7200RPM drive and installed drive in the new i7 Mac. Computer was working fine until I installed Windows via Boot Camp. I can't boot to the Mac Partition any more, the partition is there but when you try to boot to it you just see the Apple logo and NO circle. I cannot boot to the install CDs or a bootable external drive. I target disk mode the computer and used another computer to boot using the drive in the i7 unit and it's fine and I can see all the information.

    I tried booting the i7 into single user mode and saw the following message:

    efiboot loaded from device: Acpi(PNP0A03,0)/Pci(1|1)/Ata(Primary,Master)/HD(Part 2,Sig********-****-****-****-************)
    boot file path: \System\Library\CoreServices\boot.efi
    .Loading 'mach_kernel'...
    ................................................................................
    .................
    .........................................................................
    root device uuid is 'xxxxx-xxxxx-xxx-xx-xxxx'
    Loading drivers...
    Loading System\Library\Caches\com.apple.kext.caches\Startup\Extensions.mkext...

    So I try to do a clean install of the Mac OS. But I can't boot to anything Mac (external drive, install disk, internal drive) but it boots fine to windows. I had to target disk mode the computer, boot my computer to a Snow Leopard retail disk (Tried using the i7 install discs but it "can't be installed on this computer" because I am not booting from the i7). Used the retail disk and did a clean install, partition is GUID and I installed the 10.6.3 combo update. Still won't boot. Does anybody have any thoughts on this? I even used Terminal and opened the i7 install discs and installed the essentials, additional essentials and base system pkgs and it's still not working.
     
  2. ewilson6 macrumors 6502

    Joined:
    Nov 30, 2006
    #2
    place install cd in driver restart system and hold down 'C' KEY to do a clean install
     
  3. FongMan thread starter macrumors regular

    FongMan

    Joined:
    Feb 4, 2006
    #3
    Yes, i cant boot to the install discs, i have done a clean install using the install disks and another computer while target disk moding the i7 and it's still not working. I was able to get another MBP bot the i7 but the model prior and was able to use the i7 grey install disks but it's still not resolved.
     
  4. Whan macrumors newbie

    Joined:
    Aug 3, 2010
    #4
    Please tell me you found a solution to your problem... pretty please. My MBP has the exact same problem!!!! target disc mode install, no dice. Even zero'd the drive to no avail. I hope to God you have an answer! By the by there seems to be no firmware restore dmg yet released for the i7s - a little fishy I think!
     
  5. ZeroXcape macrumors newbie

    Joined:
    Aug 9, 2004
    #5
    I've got the same problem... bought the top-of-the-line 15" macbook (i7) and I can't boot to the brand new Snow Leopard DVD (10.6.3) that I just bought.

    This is so frustrating.

    Drove all around town today... and finally found this post.

    Anyone have an answer?
     
  6. NeoMayhem macrumors 6502a

    Joined:
    Aug 22, 2003
    #6
    If you hold down the option key at startup, does the CD/external drive show up as a boot option?
     
  7. v1nc3r3 macrumors newbie

    Joined:
    Nov 15, 2010
    #7
    this worked for me

    1. put a WORKING intel macbook / macpro into target disk mode and connect it to your MBP that you want to fix
    2. Start up your (non booting) MBP and hold alt
    3. Choose as your start up disk the disk of the working MBP (the one in target disk mode)
    4. after logging in, check software update and update your Mac OSX and firmwares
    5. Restart
    6. Repeat steps 1-3
    7. Put your SNL installation Disk
    8. Install SNL on the (non booting) MBP
    9. Restart after installation
    10. Put the (non booting) MBP on target disk mode and connect it to the WORKING MBP/Mac Pro
    11. Start up the WORKING MBP/ Mac Pro and hold alt
    12. Choose the HD of the (non-booting) MBP for startup
    13. Update the MacOSX Software and firmwares.
    14. Restart
     

Share This Page