i7 owners - any graphics issues?

Discussion in 'iMac' started by RichardI, Sep 15, 2010.

  1. RichardI macrumors 6502a

    RichardI

    Joined:
    Feb 21, 2007
    Location:
    Southern Ontario, Canada
    #1
    Hi gang, as shown in my sig, I have a beautiful new 27" iMac. the only complaint I have is that some of the games I play won't play right. For example: X-plane 9 will not play in full screen 2560x1440 - the screen's native resolution. I can play it just fine and get FPS in the high 90's and low 100's with just about everything turned way up as long as it's not 2560x1440. Curious, eh?
    I have an adventure game called Cleopatra, a Queen's Destiny. When I play that game, only the active portions of any screens show correctly. The rest of the screen is just vertical stripes. Anyone else out there (with the HD5750 video card) having similar issues, or could I have a faulty card?

    Rich :cool:
     
  2. Hayashi macrumors newbie

    Joined:
    Jun 10, 2008
    #2
    I don't really know for sure as I don't play any of those games, but its possibly the games itself doesn't support the 2560x1140 resolution or wide screen for that matter.
     
  3. henleyregatta macrumors newbie

    Joined:
    Jul 21, 2010
    Location:
    England
    #3
    (Possibly) Working As Designed

    I've got either the same or a very similar rig to yours[1].

    Games from Steam (e.g. Half Life 2, Portal etc) run just fine fullscreen native resolution at max detail settings (Half Life 2 with everything turned on gets 50-80 fps with occasional bog-downs to 20fps when there's a lot going on).

    Ditto the gliding sim Silent Wings runs lovely in full-screen at native resolution, again 50-80fps normally.

    X-Plane appears to be a special case. It basically doesn't like widescreen resolutions very much - 2D cockpits scale up to nearly fill the screen and you end up having to scroll around a lot to see either the outside world or the whole of the cockpit. 3d cockpits are better but depending on aircraft you'll struggle to twiddle the dials and push-buttons without zooming in. Previous releases worked a bit better - full-screen widescreen would result in a centralised cockpit display with scenery spilling-over to left and right, but Austin's changed tack with 9.x; frankly I'm not impressed.

    Having said that if I run it full-screen native resolution I normally get 50+ fps but in high-density areas with lots of weather (clouds really suck CPU) I can get the low-framerate warning (20fps) quite easily.

    In the X-plane window, do Settings -> Rendering Options. In the top section there's a "Native Resolution" and "Run Fullscreen" option which should work.

    But as I say, because of the cockpit scaling issues I find it unusable in full-screen so normally run in a 4:3-scaled window in the middle of that lovely, lovely widescreen monitor.



    [a] = Ordered my 27" i7 2 weeks before the latest refresh so I might be behind on ATI card and CPU...
     
  4. RichardI thread starter macrumors 6502a

    RichardI

    Joined:
    Feb 21, 2007
    Location:
    Southern Ontario, Canada
    #4
    Thanks henley. I think you're right on about X-plane. Since I posted the original question, I discovered that there was a newer version of the Cleopatra game that fixed the problem. I am doing the same as you for X-plane and running it in a 4:3 window. Thanks for the info.

    Rich :cool:
     

Share This Page