Resolved iAd.framework missing

Discussion in 'iOS Programming' started by Theclamshell, Mar 26, 2011.

  1. Theclamshell, Mar 26, 2011
    Last edited: Mar 26, 2011

    Theclamshell macrumors 68030

    Joined:
    Mar 2, 2009
    #1
    Hey everyone,

    First off, I downloaded Xcode 4 from the app store because i did not plan on signing up as an iOS developer where it is offered for free.

    Well, i have started making an app and it is pretty much done except some small issues which i may make a new thread for :eek:.

    My main concern is that I am missing the iAd.framework file. I paid the 99 and signed up as an iOS developer downloaded Xcode 4 from the dev portal and iAd.framework is still missing.

    I signed the iAd network contract hoping that would get me the file but it is still not there. I am not sure what to do next, any ideas?
     
  2. kingofwburg macrumors newbie

    Joined:
    Mar 26, 2011
    #2
    Do you mean it's not even available to add to your project?

    Don't know if you're fully familiar with XCode 4 yet, but you can add the iAd framework by going to your build phases, look for "Link Binary with Libraries", expand it and click the plus button. The framework should be available in there.

    If the issue is that it's not in there, I have no idea how to help other than reinstalling XCode (which would come with all of the libraries).
     
  3. Theclamshell thread starter macrumors 68030

    Joined:
    Mar 2, 2009
    #3
    Thank you so much!! I was actually able to find it in Xcode 3 and drag it over but your method worked fine and its in there now! :):)
     

Share This Page