iBank 5.1.1 crashes

Discussion in 'OS X Yosemite (10.10)' started by AndrewWx, Jul 30, 2014.

  1. AndrewWx macrumors regular

    AndrewWx

    Joined:
    Feb 10, 2005
    Location:
    Ventura CA
    #1
    Hi Everyone:

    Every time I hit the "+" button in iBank to add a new transaction the program crashes.

    I am running Yosemite on a 2011 rMBP.

    Has anyone else found this problem I see a few people have had success so I wonder if some other process is not playing nice.

    Thanks for any help
     
  2. relbhcb macrumors newbie

    Joined:
    Aug 16, 2011
    #2
    iBank 4.7.5 works OK. Does your issue also happen if you type CMD + N instead of clicking the +?
     
  3. AndrewWx thread starter macrumors regular

    AndrewWx

    Joined:
    Feb 10, 2005
    Location:
    Ventura CA
    #3
    Yup: I see the new blank transaction appear for half a second then crash. Does not matter if CMD+N or the "+" symbol. It also crashes during the download from bank after the accounts are updated (I see the little balloons for the number of new transactions pop up just before the crash) It also crashes if I hit the "skip this scheduled transaction.

    I must have some sort of incompatibility. I thought it might be Little Snitch but that was not it.

    Works fine in my Mavericks partition so I am not sweating it. Just frustrating that I seem to be the only one with the problem.
     
  4. The19th macrumors regular

    Joined:
    Jul 24, 2014
    Location:
    NorCal
    #4
    How about in a different user account? That might help narrow down if it's something combination of Yosemite, the app, or a user preference file.
     
  5. AndrewWx thread starter macrumors regular

    AndrewWx

    Joined:
    Feb 10, 2005
    Location:
    Ventura CA
    #5
    wow that took awhile. I could not open my iBank file from another account because of some weird permission issue. That I could not solve by changing the permissions. Then of course because of the known bug I could not create a new account to test.

    I took a flyer and removed the app and all of its associated permissions and did a clean install, but it did not work.

    I did discover that the "show registration" box will not show if you click on it. But that probably part of the "pop up" issue that others are also having.
     
  6. iPhil macrumors 68040

    iPhil

    #6
    IGG Software devs haven't released a Yosemite version either beta or Full release..


    iBank 5 requires Mac OS X 10.8 (Mountain Lion) or 10.9 (Mavericks).

    Bottom of page
     
  7. guntoad macrumors newbie

    guntoad

    Joined:
    Dec 30, 2013
    Location:
    UK
  8. riderj macrumors newbie

    Joined:
    May 5, 2008
    #8
    Go to IGG knowledge base and look for 5.1.2. It will work on DP4
     
  9. AndrewWx thread starter macrumors regular

    AndrewWx

    Joined:
    Feb 10, 2005
    Location:
    Ventura CA
    #9
    Well I hope this solved other people's problems. Sadly the crash on new transaction bug is still present in 5.1.2

    I will contact IGG today and see if they can solve the odd permissions bug that will allow me to edit my ibank document from another user account.

    This, so far, is my only Yosemite problem and I am quite happy with it.

    Cheers
     
  10. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #10
    www.iggsoft.com/ibank/iBank5.1.2.dmg

    Looks like they closed the KB in favor of some new and improved support system. I found this link for 5.1.2 though if it helps anybody.
     
  11. grubMF, Oct 17, 2014
    Last edited: Oct 17, 2014

    grubMF macrumors newbie

    Joined:
    Nov 13, 2009
    Location:
    noisy end of Half Moon Bay airport
    #11
    Possible fix (so far so good)

    BTW: MacBook Pro with Yosemite.

    Open your iBank file but do not enter your password, open iBank prefs and deselect "Autosave iBank documents" under the Advanced tab, and "Automatically update documents when opened" under the General tab.

    So far I've updated two credit card Accounts by selecting the card's account and manually selecting "Download transactions for selected account" in the Accounts tab.


    Crud! Saving crashed it.


    Wahoo! Save As worked, so far.


    Yep, I just "Download Quotes" and "Download Currency Exchange Rates" (in Tools), then Save As, and it worked. Still cannot update all accounts, though.
     
  12. Mariner711 macrumors newbie

    Joined:
    Oct 20, 2014
    #12
    Fixed problem with tech support

    I was able to get this problem solved through tech support by going to my data file and using "Get Info" on it. Under "Open With" and reselect Ibank 5 and then press the "Change All" button. This cleared up the issue and allowed me to turn auto save back on. Seems easy but I was on the support line trying different things for an hour.

     
  13. jmwny macrumors newbie

    Joined:
    Feb 7, 2015
    #13
    iBank 4 and Yosemite

    Hey, You said you were on iBank 4.7.5, and it works ok, are you actually using it on Yosemite? I want to upgrade to Yosemite to take advantage of a number of features, but I cannot afford to update iBank 5 yet. I have been trying to find out if anyone has had success running iBank 4 on Yosemite, I am currently on 4.7.3
    Thanks in advance ;)


     

Share This Page