iBook 14" 1.07GHz won't see battery

Discussion in 'PowerPC Macs' started by MacReader, Apr 16, 2011.

  1. MacReader macrumors newbie

    Oct 28, 2008
    I have a 14" ibook in good condition; it's never been abused or dropped.

    It worked fine until recently (the computer itself is still operational).

    I have the original Apple power cord.

    The ibook works if I plug in the power cord (with no battery in the computer), so the connector and the DC-in jack don't appear to be the problem.

    If I try to run it on battery alone, nothing happens. It doesn't power on. The battery is used, but still has some charge, is currently about 97% charged and all the battery test lights light up.

    If I put the battery into the computer and plug in the power jack, the computer works fine (off AC power) and even "sees" the battery and reports the stats.


    the little green/amber light ring on the power cord no longer lights up. It's as though the computer can "see" the battery but the power source is unable to connect to it and charge it (and it won't run from battery).

    Same problem if I swap out the power cord with another one that I know is in good shape, so it's not the power cord.

    Any idea what might be the problem? A cable, a component?
  2. Nameci macrumors 68000


    Oct 29, 2010
    The Philippines...
    have you tried to reset your PMU? Your PMU handles your power management.
  3. MacReader thread starter macrumors newbie

    Oct 28, 2008
    Resetting PMU

    Yes, I reset the PMU, I think.

    I couldn't find a physical reset button on this model, so I used the four-key combo for about 7 seconds, then let go and powered up the computer.

    No difference.

    Computer works on AC.
    Profiler reports correct statistics for battery.
    Battery lights with 4 lights and doesn't look abnormal (no gunk on the contacts, it's in clean condition).

    The ring on the AC cord does not light up and the battery does not charge.
  4. MacReader thread starter macrumors newbie

    Oct 28, 2008
    Light ring circuit?

    The symptoms have changed, slightly.

    I finally got my hands on a different battery, a fresh one, put it in the computer and the light rings lit up yellow and the computer started charging, so it is, apparently capable of charging a battery as long as it sees it.

    But... when it reached full charge, instead of turning green, the light shut off.

    I swapped out battery again, and yellow light came on, it charged up, but this time, it stays yellow even when the battery is fully charged.

    So... it appears to be something with the AC light ring circuit. Since the computer is controlling that (it behaves the same with different power cords, so it's not the power cord), is the light ring control circuit on the DC-in power jack circuit board? Or is it elsewhere?
  5. Nameci macrumors 68000


    Oct 29, 2010
    The Philippines...
    i think most probably is that you have some issues with your dc in board which takes care of your charging...

Share This Page