iBook ethernet problem

Discussion in 'Macintosh Computers' started by guava, Aug 31, 2005.

  1. guava macrumors newbie

    Aug 21, 2005
    Well I have a small problem with my newly purchased iBook. I can't connect to the internet with the build in ethernet plug. It worked flawlessly just till half an hour ago. Now I cannot connect to the internet anymore. Is the ethernet plug broken or is it something due to software problems. I'm currently not at home, it worked without any problems, now i'm a friend and it only worked for about half an hour.

    I find it really bizarre because my PC doesn't have any problems when connecting to the internet when using the same cable.

    Is there anyone with a solution?
  2. Le Big Mac macrumors 68030

    Le Big Mac

    Jan 7, 2003
    Washington, DC
    Does your friend have a router or is he directly connected to a cable modem/dSl? Perhaps they have a MAC address limit, and they think you're sharing the internet access contrary to TOS. Or try refreshing the DHCP in the network prefs. pane.
  3. yellow Moderator emeritus


    Oct 21, 2003
    Portland, OR
    What troubleshooting have you done? A restart?
  4. wwooden macrumors 68000


    Jul 26, 2004
    Burlington, VT
    are you connecting directly to the modem? I know that sometimes if you have a computer connected directly, then you try to connect another one, you have to unplug the modem, let it for for a minute then connect it to the new computer.

Share This Page