iBook G3 Problems... I've tried everything!!!

Discussion in 'PowerPC Macs' started by p0intblank, Jun 13, 2007.

  1. p0intblank macrumors 68030

    Sep 20, 2005
    New Jersey
    I have a friend's iBook G3 that I am working on. The hard drive is already formatted and ready to go. I've tried to install OS 9, Panther, and Tiger...

    OS 9 doesn't even start because of a "system bus" error. Panther and Tiger both install, but I can never seem to boot into the full OS successfully. I've tried everything. I've even tried installing OS X onto my 3G iPod and cloning the drive. That got me the furthest, but the MenuBar refused to completely load, thus forcing the desktop to reload an infinite amount of times.

    I've removed one of the RAM modules and that doesn't seem to fix anything. The same goes for repairing disk permissions.

    Does anyone have any solution to this? It's been driving me crazy and I just want to get this iBook back into my friend's hands.

    Thanks in advance!

Share This Page