iBook G4 1.42 not recognizing new ram

Discussion in 'PowerPC Macs' started by hyprmrt, Dec 26, 2006.

  1. hyprmrt macrumors newbie

    Dec 26, 2006
    I've already RMA'd the first 1gb stick back to Crucial, and now I'm on the second-- same problems.

    Sometimes the system boots, sometimes it hangs at a blank screen until I hold the power button down long enough to turn it off. But when I CAN actually get up and running, "About This Mac" reports that I only have the onboard 512mb. System Profiler says my singular expansion slot as empty!

    Yes, I've tried re-seating it-- many times. To no avail. I'm also positive the module is as far into the slot as it can go. And I find it hard to believe that Crucial would send me two faulty sticks in a row. Unfortunately, due to my built-in 512mb, I can't boot off the Crucial ram alone.

    Any ideas?
  2. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Is it the appropriate type of RAM? Is it sold as Mac-friendly? :)
  3. Irish Dave macrumors regular

    Nov 20, 2006
    The Emerald Isle
    Is it seated properly?

    Dave :)
  4. CanadaRAM macrumors G5


    Oct 11, 2004
    On the Left Coast - Victoria BC Canada
    #1 problem withn SODIMMs:

    When you have the RAM up on the 30 - 45 degree anhle as you are fitting the contact edge into the socket pins - you HAVE to apply moderate pressure with your thumbs on the long edge of the RAM module to properly seat the contacts into the socket. THEN lay the RAM down flat. It cannot be done after the RAM is clicked flat into the socket. The clips clicking into place are no indication that the connectors are all the way into the socket. Look at the RAM where it is in the socket - if you can see 1. mm or more of the gold connector pads, then it is not installed properly. Take it out and start again.

    Now, there is a chance that you have a bad module. But more often than not, it's improper installation.

    Did you buy the specific RAM for your Mac model and speed, or did you choose by generic description? The generic Crucials can be incompatible with some models of Mac. You know your 1.42 requires PC2700, not PC2100, correct? It's the only iBook G4 that doesn't take PC2100 (266 MHz) RAM.
  5. hyprmrt thread starter macrumors newbie

    Dec 26, 2006
    Yes-- when I ordered the ram from Crucial, I selected based on my exact iBook model. I know macs can be picky about ram and didn't want to mess with generics.

    It's PC 2700, and as I stated before this is the second stick-- I RMA'd the first back to crucial.

    I'll try jamming it in there at the 45 degree angle before laying it down flat. Maybe that's the one thing I neglected to do!
  6. hyprmrt thread starter macrumors newbie

    Dec 26, 2006
    Nope, no luck. Nothing has changed. Tried three more times.

    There's nowhere left for the module to go-- it's been pressed in as hard as I could press it and I'm getting the same problems as before.

    I hit the power button and get the startup chime, then nothing happens. I wait a couple of minutes and the HD never spins up. The screen never turns on. So I hold down the power button and hear a "click" from the speakers as it shuts off.

    Hit the power button again and it starts up seemingly normal. Except that when I check out "About This Mac" it says I only have the base 512mb installed. System Profiler says the ram expansion slot is empty.


    Would a picture of "how far" I've inserted the stick help? There IS a little bit of the gold connectors showing, but I swear I can't put it any further in.
  7. hyprmrt thread starter macrumors newbie

    Dec 26, 2006
  8. Irish Dave macrumors regular

    Nov 20, 2006
    The Emerald Isle
    Yes it looks fine.

    It does seem unlikely that you would get two faulty memory sticks from Crucial. But to prove it can you borrow another stick you know is working, and try it.

    Dave :cool:

Share This Page