iBook G4 Boot Problems!!!

Discussion in 'PowerPC Macs' started by haiggy, Jun 11, 2006.

  1. haiggy macrumors 65816

    Aug 20, 2003
    Ontario, Canada
    So I was minding my own business, talking on Adium with Safari, WC3 and Team Speex open and went to check the date in the menu bar. I clicked it, and my computer totally froze. I could move my mouse, everything else was unresponsive.

    So in response, I force booted it and I heard everything start up as usual... start up chime, everything... and the screen came on to load. Apple logo with spinning loading wheel..... as soon as the spinning wheel stopped... as in where it would normally show the log in screen progess bar loading up, the computer completely shut off. I tried again. Same thing. I kept trying and trying and eventually the start up chime wouldn't even sound.

    I'm going to try resetting the PRAM, fsck etc right now... other than that any ideas? Also I don't know where my Hardware Test CD is... is it the Tiger Install CD? Because otherwise I can't find it which is really odd seeing as I didn't misplace it... UGH!

    Your help is grately appreciated. Sucks if its the logic board gone. Such a shame too, because I wasn't doing anything to screw it up. This machine is 2 years + a few months old... no AppleCare so if its the logic board I might have to get a new machine. Sigh........ here goes my summer job earnings....

  2. haiggy thread starter macrumors 65816

    Aug 20, 2003
    Ontario, Canada
    So I tried resetting the PRAM... same problem only it returned the start up chime.

    Then I tried the fsck -f command in single user mode. This came up with:
    Everything going fine until
    Checking Catalog file.
    - Invalid index key (4, 23525)
    "The volume Macintosh HD could not be repaired. Some errors were found that were not repaired. You should attempt to repair the disk again." So I did, and the same thing happened. Then it gave me this message. "The disk directory is not healthy." in yellow print. ?????

    I could hear the hard drive spinning and clicking and working...

    So then I repaired permissions.... this came up but I don't know if it is significant.. "parent directory ./Users/Shares/SC Info does not exist"

    Sooo then I cleared the cache as well. Finished up and typed reboot.

    Now it works.

    Anybody know what the problem could have been? Do you think it's possible my computer froze because the virtual memory ate up all of the hard drive space? I have like 4 GB left on my drive (out of 60GB).

    Thanks anyways :eek:
  3. mad jew Moderator emeritus

    mad jew

    Apr 3, 2004
    Adelaide, Australia
    Get more free space, if possible. Aim for 8GB plus. Also, did you keep running fsck until it made no changes? :)

Share This Page