Become a MacRumors Supporter for $25/year with no ads, private forums, and more!

Resolved iBook G4 can't connect to network.

nickn

macrumors 6502
Original poster
Jun 17, 2011
386
0
My iBook G4 can't seem to get a valid ip address from my router. Both the stock airport extreme card and built in wired Ethernet nic only manage to get a generic 169 range self assigned ip, which doesn't work. All of the other wireless and wired clients on the network don't have any DHCP issues though, meaning the iBook is at fault. I requested a DHCP refresh in the system settings, restarted the router, and reseated/cleaned the airport card, but nothing changed. I also manually filled out the TCP/IP settings pan, but despite the system preferences changing to say that the network is fine, it is not. I still have no connectivity. I should also add the iBook has worked fine with the router, a Netgear WNDR3300, for about a year now, so I don't think there any compatibility problems. Any ideas what the issue could be here, or how I could fix this?
 
Last edited:

eyoungren

macrumors Core
Aug 31, 2011
22,639
15,596
ten-zero-eleven-zero-zero by zero-two
Are you on Leopard?

If so, try this. Turn off Airport. Go to System Preferences>Security and click on your Firewall tab. Click on the radio button for Allow all incoming connections. Turn Airport back on and then check in Network that you have a valid IP. Then you can change the Firewall settings back if you want.

This is a little bug in Leopard I ran into a year ago. There is another route which involves deleting Airport and Network preferences, but it doesn't stick for long and it requires a series of steps and a couple of restarts. It's easier just to turn the Firewall off.
 
Last edited:
Comment

nickn

macrumors 6502
Original poster
Jun 17, 2011
386
0
Are you on Leopard?

If so, try this. Turn off Airport. Go to System Preferences>Security and click on your Firewall tab. Click on the radio button for Allow all incoming connections. Turn Airport back on and then check in Network that you have a valid IP. Then you can change the Firewall settings back if you want.

This is a little bug in Leopard I ran into a year ago.

Thanks for the info!!!!! You were correct. After turning off the firewall, both of the interfaces are running fine now. I guess the bug will never get fixed, as I am indeed on leopard.
 
Comment

eyoungren

macrumors Core
Aug 31, 2011
22,639
15,596
ten-zero-eleven-zero-zero by zero-two
Cool, glad it's working.

My wife had this happen to her with her PB one night last year. I spent an hour or so looking for the solution. Found it on some blog somewhere (I think I have a bookmark) from a guy that had the problem too (with his girlfriend's Mac).

Of course, once I fixed my wife's Mac by just turning the firewall off it showed up on both of MY PowerBooks! At least I knew what was going on that time though.

Surprisingly enough, this little bug does not seem to be very well known over at the Apple forums.
 
Last edited:
Comment

charudut

macrumors newbie
Jun 28, 2014
2
0
Thanks a lot man!

Are you on Leopard?

If so, try this. Turn off Airport. Go to System Preferences>Security and click on your Firewall tab. Click on the radio button for Allow all incoming connections. Turn Airport back on and then check in Network that you have a valid IP. Then you can change the Firewall settings back if you want.

This is a little bug in Leopard I ran into a year ago. There is another route which involves deleting Airport and Network preferences, but it doesn't stick for long and it requires a series of steps and a couple of restarts. It's easier just to turn the Firewall off.

Your solution worked like butter! I tired all the replies in Apple communities, but no luck. This was exactly the solution to my problem.
 
Comment

moongypsy524

macrumors newbie
Oct 11, 2016
4
1
Wilmington,NC
My iBook G4 can't seem to get a valid ip address from my router. Both the stock airport extreme card and built in wired Ethernet nic only manage to get a generic 169 range self assigned ip, which doesn't work. All of the other wireless and wired clients on the network don't have any DHCP issues though, meaning the iBook is at fault. I requested a DHCP refresh in the system settings, restarted the router, and reseated/cleaned the airport card, but nothing changed. I also manually filled out the TCP/IP settings pan, but despite the system preferences changing to say that the network is fine, it is not. I still have no connectivity. I should also add the iBook has worked fine with the router, a Netgear WNDR3300, for about a year now, so I don't think there any compatibility problems. Any ideas what the issue could be here, or how I could fix this?
Thank you so much for this....i had the same problem witrh my other ibook and this fixed it,ive been messing with it trying to figure this out for days!!!THanks!!!
 
  • Like
Reactions: eyoungren
Comment

sawpits

macrumors regular
Feb 28, 2014
169
67
Are you on Leopard?

If so, try this. Turn off Airport. Go to System Preferences>Security and click on your Firewall tab. Click on the radio button for Allow all incoming connections. Turn Airport back on and then check in Network that you have a valid IP. Then you can change the Firewall settings back if you want.

This is a little bug in Leopard I ran into a year ago. There is another route which involves deleting Airport and Network preferences, but it doesn't stick for long and it requires a series of steps and a couple of restarts. It's easier just to turn the Firewall off.


Happened to me as well last year, after having the firewall turned on for a few years. So why? Who knows. And when I turn the firewall back on, sure enough, a few days later, it happens again.
 
  • Like
Reactions: eyoungren
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.