iBook G4 Ethernet cable Problem... Any thoughts?

Discussion in 'PowerPC Macs' started by Nar1117, Jun 15, 2006.

  1. Nar1117 macrumors 6502

    Apr 15, 2006
    Hey, a friend of mine is having a slight problem with his G4 iBook, and i wondered if anyone could help...

    Heres the problem: A while ago, he could plug in an ethernet cable that was connected to a router and connect to the internet with no problems or changing of settings. Its a mac, so this is normal. Then, just the other day, he plugged in to the same cable at my house and the iBook didnt even recognize that there was an ethernet cable plugged in, much less connect to the internet. I went into network setting and the dot next to the 'built in ethernet' option was red, obviously meaning it wasnt working for some reason. He didnt change any settings from the last time he connected, so im thinking it could be a hardware issue. Any thoughts?

    Thanks for the help in advance...
  2. Gokhan macrumors 6502a

    Oct 7, 2003

    ı would try restartıng osx wıth the cable plugged ın and see ıf osx pıcks atleast the cable ! also verıfy that the ethnet port woeks by tryıng a known workıng ınternet connectıon.
  3. Nar1117 thread starter macrumors 6502

    Apr 15, 2006
    Well the reason im asking this question is because when we did plug it into a known internet connection, it didnt work, and OS X did not recognize that there was an ethernet cable plugged in. This leads me to believe that it could be a hardware problem.
  4. Gokhan macrumors 6502a

    Oct 7, 2003

    then ıts hardware ım afaırd check the pıns ınsıde the ethernet port to make sure there not damaged other than that ull need a steady hand to repaır ıt or u mıght be able to replace just the port but ıt would cost
  5. timswim78 macrumors 6502a


    Feb 8, 2006
    Baltimore, MD
  6. SC68Cal macrumors 68000

    Feb 23, 2006
  7. uberpenguin macrumors newbie


    Try this... create a new location in Network Preferences, turn off all network ports except ethernet. Then hook the ibook up to another mac with the ethernet cables, give them both private statics ips, and see if you can share files between them. If that doesn't work, I suggest
    1. new cable
    2. Apple Hardware test on system restore CDs
    2. new user account on the amc
    3. Check to make sure there weren't any updates for firmware for that model
    4. If there is an apple store nearby have one of the "genius" bar people actually test the ethernet port on the board for you
    5. If all else fails tell your friend to spend 10 bucks and get a usb ethernet adapter.
  8. uberpenguin macrumors newbie


    Bad idea. That port is sodered to the board. Have to replace entire board.
  9. imacintel macrumors 68000

    Mar 12, 2006
    If you have a network dependent login, do NOT restart. You won't be able to connect to your server if it doesn't work. At my school, the backround looks says this, it looks like police tape in the backround:


    It also has a box at the bottom, that says:

    Please check your network connection, as it isnt availble.
    Please check the connection and restart.
  10. Nar1117 thread starter macrumors 6502

    Apr 15, 2006
    Thanks everyone for the help...

    I know its not the cable, we used the same cable on an iMac and it worked fine...

    I did network Diagnostics and it said that no cables were connected and some other crap that basically meant that it couldnt detect anything coming from the Ethernet port. When i go into netowrk settings and look at the Network status for any location that has ethernet enabled/turned on, no 'ethernet' option is showing up in the network status box. Airport works fine, bluetooth works fine... but no ethernet.

    When i get a chance i will attempt Uberpenguin's idea of sharing files between macs. I know that its not a user problem, we tried it on the Admin account with the same results.

    The thing that really makes me think that its hardware is that when we restarted the OS with the cable plugged in, OS X recognized the internet connection with no problem and then the internet stopped working a few minutes later with no changed variables. ANYway... Thanks everyone for the support.

Share This Page